<!DOCTYPE html>

  <!--[if lt IE 7 ]><html class="no-js ie ie6 oldie" lang="en"> <![endif]-->
  <!--[if IE 7 ]><html class="no-js ie ie7 oldie" lang="en"> <![endif]-->
  <!--[if IE 8 ]><html class="no-js ie ie8 oldie" lang="en"> <![endif]-->
  <!--[if IE 9 ]><html class="no-js ie ie9" lang="en"> <![endif]-->
  <!--[if (gte IE 9)|!(IE)]><!--><html lang="en" class="loaded"> <!--<![endif]-->
  <head>
    <title>Longboat Key mayor writes letter to Gov. Ron DeSantis on COVID-19 vaccine distributions | Longboat Key | Your Observer</title>

    <!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="google-site-verification" content="NhzK4FRO_M2NOv6dXIvbzW8cP7sCfyrssSGx8x1jWkU"/><meta property="fb:pages" content="288643121405"/><meta name="google-site-verification" content="NhzK4FRO_M2NOv6dXIvbzW8cP7sCfyrssSGx8x1jWkU"/><meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests"/><meta property="fb:app_id" content="949279485485509"/><link rel="amphtml" href="https://www.yourobserver.com/article/longboat-key-mayor-writes-governor-on-covid-19-vaccines?amp" />
<link rel="shortcut icon" href="https://www.yourobserver.com/sites/all/themes/yourobserver/favicon.ico" />
<script>dataLayer = [{"entityType":"node","entityBundle":"planned_story","entityId":"695629","entityLabel":"Longboat Key mayor writes governor on COVID-19 vaccines","entityLanguage":"und","entityTnid":"0","entityVid":"696290","entityName":"admin","entityUid":"1","entityCreated":"1611258186","entityStatus":"1","entityTaxonomy":{"planned_story_type":{"1":"Article"},"publication":{"6":"Longboat Key"},"planned_story_section":{"10":"News"}},"drupalLanguage":"en","userUid":0,"entityAuthor":"Mark Bergin"}];</script>
<meta name="description" content="The letter asks Gov. Ron DeSantis to prioritize distributing the vaccine to the most vulnerable populations." />
<meta name="keywords" content="Ron DeSantis, Ken Schneier, BJ Bishop, Longboat Key, COVID-19, coronavirus, COVID-19 vaccine sites, COVID-19 vaccinations, COVID-19 Longboat Key, Longboat Key COVID-19" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.yourobserver.com/article/longboat-key-mayor-writes-governor-on-covid-19-vaccines" />
<link rel="shortlink" href="https://www.yourobserver.com/node/695629" />
<meta property="og:site_name" content="Your Observer" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Longboat Key mayor writes letter to Gov. Ron DeSantis on COVID-19 vaccine distributions | Longboat Key | Your Observer" />
<meta property="og:url" content="https://www.yourobserver.com/article/longboat-key-mayor-writes-governor-on-covid-19-vaccines" />
<meta property="og:description" content="The letter asks Gov. Ron DeSantis to prioritize distributing the vaccine to the most vulnerable populations." />
<meta property="og:updated_time" content="2021-01-21T20:30:02-05:00" />
<meta property="og:image" content="https://www.yourobserver.com/sites/default/files/324107_standard.jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.yourobserver.com/article/longboat-key-mayor-writes-governor-on-covid-19-vaccines" />
<meta name="twitter:title" content="Longboat Key mayor writes governor on COVID-19 vaccines" />
<meta name="twitter:description" content="The letter asks Gov. Ron DeSantis to prioritize distributing the vaccine to the most vulnerable populations." />
<meta name="twitter:image" content="https://www.yourobserver.com/sites/default/files/324107_standard.jpeg" />
<meta property="article:published_time" content="2021-01-21T14:43:06-05:00" />
<meta property="article:modified_time" content="2021-01-21T20:30:02-05:00" />

    <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
    <meta name="google-site-verification" content="W5qEe1V8ciPqgo7dPyNIXQ-wHbIW1dBCGQ-dzCLvNgQ" />

    <meta http-equiv="cleartype" content="on">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

              
          <link rel="alternate" type="application/rss+xml" title="RSS Feed | Your Observer" href="https://www.yourobserver.com/article/rss/longboat-key/news" />    
    <link rel="shortcut icon" href="https://www.yourobserver.com/sites/all/themes/yourobserver/favicon.ico?v=1.3">
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-152x152.png">
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-144x144.png">
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-120x120.png">
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-114x114.png">
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-72x72.png">
<link rel="apple-touch-icon-precomposed" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-57x57.png">
    <link rel="stylesheet" href="https://www.yourobserver.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" />
<link rel="stylesheet" href="https://www.yourobserver.com/sites/default/files/css/css_LGPfSzKpPyt30S4DeUQesoVz1kT21vSiBb1TrW-1DyY.css" />
<link rel="stylesheet" href="https://www.yourobserver.com/sites/default/files/css/css_1KW0C7ctCmnKsTdL4yl3ho7AL_FCFLpCjlxw3PgdM7M.css" />
<link rel="stylesheet" href="https://www.yourobserver.com/sites/default/files/css/css_47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU.css" />

    <!--[if lte IE 8]>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/respond.js"></script>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/selectivizr.js"></script>
    <![endif]-->
    <!--[if lt IE 9]>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/html5shiv.js"></script>
    <![endif]-->

    <script src="/sites/default/files/google_tag/google_tag.script.js?qnbc81"></script>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.9/jquery.min.js'>\x3C/script>")</script>
<script src="/misc/jquery-extend-3.4.0.js?v=1.9.1"></script>
<script src="/misc/jquery-html-prefilter-3.5.0-backport.js?v=1.9.1"></script>
<script src="/misc/jquery.once.js?v=1.2"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="/misc/drupal.js?qnbc81"></script>
<script>jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"yourobserver","theme_token":"mj2xaDTT5HcYNbDxJBtHCV4XPEccRzEj8G9vkoY9Mao","js":{"\/sites\/all\/modules\/custom\/tog_most_popular\/js\/tog_most_popular_track.js":1,"sites\/all\/themes\/yourobserver\/scripts\/dist\/app.js":1,"sites\/all\/themes\/yourobserver\/scripts\/ads.js":1,"sites\/all\/themes\/yourobserver\/scripts\/block_buster.js":1,"\/sites\/all\/modules\/custom\/tog_most_popular\/js\/tog_most_popular.js":1,"\/sites\/all\/modules\/features\/tog_planned_story\/js\/tog_planned_story_share.js":1,"\/sites\/all\/modules\/features\/tog_planned_story\/js\/tog_planned_story_related.js":1,"\/sites\/all\/modules\/features\/tog_people\/js\/tog_people_stories.js":1,"\/sites\/all\/modules\/features\/tog_planned_story\/js\/tog_planned_story_disqus.js":1,"public:\/\/google_tag\/google_tag.script.js":1,"\/\/ajax.googleapis.com\/ajax\/libs\/jquery\/1.9.1\/jquery.min.js":1,"misc\/jquery-extend-3.4.0.js":1,"misc\/jquery-html-prefilter-3.5.0-backport.js":1,"misc\/jquery.once.js":1,"https:\/\/www.googletagservices.com\/tag\/js\/gpt.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/contrib\/disqus\/disqus.js":1,"sites\/all\/modules\/contrib\/datalayer\/datalayer.js":1,"sites\/all\/themes\/yourobserver\/scripts\/dist\/modernizr.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/comment\/comment.css":1,"sites\/all\/modules\/contrib\/date\/date_api\/date.css":1,"sites\/all\/modules\/contrib\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/contrib\/logintoboggan\/logintoboggan.css":1,"modules\/node\/node.css":1,"modules\/search\/search.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/contrib\/views\/css\/views.css":1,"sites\/all\/modules\/contrib\/ctools\/css\/ctools.css":1,"sites\/all\/themes\/yourobserver\/css\/style.css":1,"sites\/all\/themes\/mothership\/mothership\/mothership\/css\/normalize.css":1,"sites\/all\/themes\/mothership\/mothership\/mothership\/css\/mothership-default.css":1,"sites\/all\/themes\/mothership\/mothership\/mothership\/css\/mothership-layout.css":1,"sites\/all\/themes\/mothership\/mothership\/mothership\/css\/mothership.css":1,"sites\/all\/themes\/yourobserver\/system.messages.css":1,"sites\/all\/themes\/yourobserver\/comment.css":1,"sites\/all\/themes\/yourobserver\/node.css":1,"sites\/all\/themes\/yourobserver\/mothership.css":1,"sites\/all\/themes\/yourobserver\/mothership-layout.css":1,"sites\/all\/themes\/yourobserver\/mothership-default.css":1,"sites\/all\/themes\/yourobserver\/normalize.css":1,"sites\/all\/themes\/yourobserver\/mothership-devel-mediaqueries.css":1,"sites\/all\/themes\/yourobserver\/reset-html5.css":1,"sites\/all\/themes\/yourobserver\/contextual.css":1,"sites\/all\/themes\/yourobserver\/reset.css":1,"sites\/all\/themes\/yourobserver\/views.css":1,"sites\/all\/themes\/yourobserver\/date.css":1,"sites\/all\/themes\/yourobserver\/system.menus.css":1,"sites\/all\/themes\/yourobserver\/system.theme.css":1,"sites\/all\/themes\/yourobserver\/date_views.css":1,"sites\/all\/themes\/yourobserver\/adaptive-image.css":1}},"author_id":"566954","ps_nid":"695629","ps_pub_id":"6","ps_sec_id":"all","ps_type_id":"all","ps_node_type":"planned_story","track_nid":"695629","urlIsAjaxTrusted":{"\/article\/longboat-key-mayor-writes-governor-on-covid-19-vaccines":true},"ad_page_type":"article","ad_slot_top":"half_page","ad_slot_bottom":"stacked_bottom","ad_slot_bottom_2":"stacked_bottom_2","ad_slot_stacked_top":"stacked_top","disqus":{"domain":"yourobserver","url":"https:\/\/www.yourobserver.com\/article\/longboat-key-mayor-writes-governor-on-covid-19-vaccines","title":"Longboat Key mayor writes governor on COVID-19 vaccines","identifier":"yourobserver\/695629"},"dataLayer":{"languages":{"en":{"language":"en","name":"English","native":"English","direction":0,"enabled":1,"plurals":0,"formula":"","domain":"","prefix":"","weight":0,"javascript":""}}},"esp_paywall_enabled":0,"enable_landing_page_email_signup":1,"ad_refresh_desktop_header":1,"ad_refresh_desktop_stacked_top":1,"ad_refresh_mobile_stacked_top":1,"ad_refresh_desktop_top_med_rec":1,"ad_refresh_desktop_bottom_med_rec":1,"ad_refresh_desktop_bottom_med_rec_2":1,"ad_refresh_desktop_footer":1,"ad_refresh_mobile_header":1,"ad_refresh_mobile_top_med_rec":1,"ad_refresh_mobile_bottom_med_rec":1,"ad_refresh_mobile_bottom_med_rec_2":1,"ad_refresh_mobile_footer":1,"referrer_modal_enabled":2,"related_modal_enabled":7,"ad_refresh_enabled":1,"ad_refresh_timeout":180000,"page_refresh_enabled":1,"article_signup_enabled":8,"block_buster_enabled":1,"password":{"strengthTitle":"Password compliance:"},"type":"setting"});</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([1018, 0], [[970, 66], [970, 90], [728, 90]])
  .addSize([0, 0], [320, 50])
  .build();
googletag.slots["footer"] = googletag.defineSlot("/30582678/OMG/yourobserver/longboat-key/news", [[970, 66], [320, 50], [970, 90], [728, 90]], "dfp-ad-footer")
  .addService(googletag.pubads())
  .setTargeting("pos", "btf")
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([1018, 0], [970, 250])
  .addSize([0, 0], [320, 100])
  .build();
googletag.slots["billboard"] = googletag.defineSlot("/30582678/OMG/yourobserver/longboat-key/news", [[970, 250], [320, 100]], "dfp-ad-billboard")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf")
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([1018, 0], [[970, 66], [970, 90], [728, 90]])
  .addSize([0, 0], [320, 50])
  .build();
googletag.slots["header"] = googletag.defineSlot("/30582678/OMG/yourobserver/longboat-key/news", [[970, 66], [320, 50], [970, 90], [728, 90]], "dfp-ad-header")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf")
  .defineSizeMapping(mapping);</script>
<script>googletag.slots["half_page"] = googletag.defineSlot("/30582678/OMG/yourobserver/longboat-key/news", [[300, 250], [300, 600]], "dfp-ad-half_page")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf");</script>
<script>googletag.slots["stacked_top"] = googletag.defineSlot("/30582678/OMG/yourobserver/longboat-key/news", [300, 250], "dfp-ad-stacked_top")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf");</script>
<script>googletag.slots["stacked_bottom"] = googletag.defineSlot("/30582678/OMG/yourobserver/longboat-key/news", [300, 250], "dfp-ad-stacked_bottom")
  .addService(googletag.pubads())
  .setTargeting("pos", "stf");</script>
<script>googletag.slots["stacked_bottom_2"] = googletag.defineSlot("/30582678/OMG/yourobserver/longboat-key/news", [300, 250], "dfp-ad-stacked_bottom_2")
  .addService(googletag.pubads())
  .setTargeting("pos", "btf");</script>
<script>googletag.slots["sticky_footer"] = googletag.defineOutOfPageSlot("/30582678/OMG/yourobserver/longboat-key/news", "dfp-ad-sticky_footer")
  .addService(googletag.pubads());</script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
  googletag.pubads().setTargeting("ob_paper", "Longboat Key");
  googletag.pubads().setTargeting("ob_section", "News");
  googletag.pubads().setTargeting("hostname", "www.yourobserver.com");
  googletag.pubads().setTargeting("url_arg_0", "article");
  googletag.pubads().setTargeting("url_arg_1", "longboat-key-mayor-writes-governor-on-covid-19-vaccines");
  googletag.pubads().setTargeting("ob_type", "Article");
  googletag.pubads().setTargeting("page-type", "Article");
  googletag.pubads().setTargeting("page-type", "article");
});

googletag.enableServices();</script>
<script src="/sites/all/modules/contrib/disqus/disqus.js?qnbc81"></script>
<script src="/sites/all/modules/contrib/datalayer/datalayer.js?qnbc81"></script>
<script src="/sites/all/themes/yourobserver/scripts/dist/modernizr.js?qnbc81"></script>
    
  </head>

  <body class="not-front no-sidebars node-type-planned-story no--top-ad no--billboard-ad no--mid-leaderboard-ad no--footer-ad no--stacked-top no--stacked-bottom no--sponsored" >
    
    
  
  <a href="#content--wrapper" class="element-invisible element-focusable">
    Skip to main content  </a>

  
  <noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TK5NRZ" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript>
  

<!--  mobile--only mobile--hide -->
<div id="data_policy" class="data-policy-container bg--mild-grey" style="padding:20px 0 20px 0; width: 100%; height: auto; display: none;">
  <div style="width: 85%; height: auto; margin: 0 auto;">
    <p style="margin-bottom: 10px;"><span class="mobile--hide">The Observer Media Group Inc. respects your privacy and values the relationship we have with you. We use technology to collect information that helps us enhance your experience and our products and services. The cookies we use help us understand what information and advertising are most useful and valuable.</span> Please take a moment to review our <a href="/cookie-policy">Cookie Policy</a> and <a href="/privacy-policy">Privacy Policy</a>. By clicking "Accept," you agree to our use of cookies and similar technologies.</p>
    <div class="accept-privacy-button" style="margin:auto; width: 100px; padding: 5px; border-radius: 5px;background: #9F0014; text-align: center;">
      <a id="privacy_button" href="#" style="color: white;">Accept</a>
    </div>
  </div>
</div>

  <div id="billboard_ad" class="advert-bar--billboard">
    <div class="advert-wrapper">
      <div id="dfp-ad-billboard-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-billboard" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-billboard");
      });
  </script>
</div>
</div>    </div>
  </div>

  <header class="main-header" role="banner">
      <div class="site--header bg--red">

  <div class="nav--top">
    <a href="/" title="Home" rel="home" class="logo">
      <img src="/sites/all/themes/yourobserver/images/logos/logo-bright.svg" alt="Home" />
    </a>
    <div class="right-nav right">
      <div class="secondary-nav">
      	<ul class="links"><li class="first leaf item-wrapper-level-1 item-1851-wrap"><a href="/spotlight/elections" class="item-1851 item-level-1">Elections</a></li>
<li class="leaf item-wrapper-level-1 item-1924-wrap"><a href="/lists/all/health/all" class="item-1924 item-level-1">Health</a></li>
<li class="leaf item-wrapper-level-1 item-1877-wrap"><a href="http://www.businessobserverfl.com/" target="_blank" class="item-1877 item-level-1">Business</a></li>
<li class="leaf item-wrapper-level-1 item-1876-wrap"><a href="/calendar" class="item-1876 item-level-1">Calendar</a></li>
<li class="leaf item-wrapper-level-1 item-1183-wrap"><a href="/lists/all/real-estate/all" class="item-1183 item-level-1">Real Estate</a></li>
<li class="leaf item-wrapper-level-1 item-1198-wrap"><a href="/redpages" class="item-1198 item-level-1">RedPages</a></li>
<li class="collapsed item-wrapper-level-1 item-1199-wrap"><a href="/contests" class="item-1199 item-level-1">Contests</a></li>
<li class="last leaf item-wrapper-level-1 item-1184-wrap"><a href="/e-editions?publication=220" class="item-1184 item-level-1">E-Newspaper</a></li>
</ul>      </div>
      <div id="weather" class="header-module--weather bg--light-red">
        <span class="icon moon-icon "></span><span class="temp">59</span>
        <span class="date right"></span>
      </div>
    </div>

    <span class="mobile-trigger search mobile--only" data-class="search">
      <span class="icon search-icon"></span>
    </span>
    <span class="mobile-trigger close-search mobile--only" data-class="search">
      <span class="icon close-icon"></span>
    </span>
    <div class="mobile-trigger menu mobile--only" data-class="menu">
      <span class="icon menu-icon"></span>
    </div>

    <div class="header-search mobile--only">
      <form action="/article/longboat-key-mayor-writes-governor-on-covid-19-vaccines" method="post" id="search-block-form" accept-charset="UTF-8">
  <h2 class="element-invisible">Search form</h2>

<div>
  <label class="element-invisible" for="edit-search-block-form--2">Search</label>
 <input title="Enter the terms you wish to search for." placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="30" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" /></div><input type="hidden" name="form_build_id" value="form-9AIp1o7yMwR7icoIG3bdoXRCsSdTajvtPAJdBoYruwg" />
<input type="hidden" name="form_id" value="search_block_form" />
</form>    </div>

  </div>

  <div class="nav--bottom sticky-container">
    <div class="bg--dark-red sticky" data-margin="0" data-position="fixed">
      <div class="container">
        <a class="logo" href="/" title="Home" rel="home" class="logo">
          <img class="full" src="/sites/all/themes/yourobserver/images/logos/logo-white.svg" alt="Your Observer">
        </a>
        <nav class="site--main-nav" data-prepend=".right-nav" data-original=".nav--bottom .container">
          <ul class="links"><li class="first expanded item-wrapper-level-1 item-1135-wrap"><a href="/longboat-key" class="item-1135 item-level-1">Longboat Key</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1164-wrap"><a href="/lists/longboat-key/news/all" class="item-1164 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1165-wrap"><a href="/lists/longboat-key/opinion/all" class="item-1165 item-level-2"><span class="icon i-arrow-right-small"></span> Opinion</a></li>
<li class="leaf item-wrapper-level-2 item-1166-wrap"><a href="/lists/longboat-key/religion/all" class="item-1166 item-level-2"><span class="icon i-arrow-right-small"></span> Religion</a></li>
<li class="leaf item-wrapper-level-2 item-1170-wrap"><a href="/lists/longboat-key/cops-corner/all" class="item-1170 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1167-wrap"><a href="/lists/longboat-key/sports/all" class="item-1167 item-level-2"><span class="icon i-arrow-right-small"></span> Sports</a></li>
<li class="leaf item-wrapper-level-2 item-1168-wrap"><a href="/lists/longboat-key/neighbors/all" class="item-1168 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1263-wrap"><a href="/lists/longboat-key/business/all" class="item-1263 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="leaf item-wrapper-level-2 item-1265-wrap"><a href="/lists/longboat-key/real-estate/all" class="item-1265 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
<li class="leaf item-wrapper-level-2 item-1262-wrap"><a href="/lists/longboat-key/your-town/all" class="item-1262 item-level-2"><span class="icon i-arrow-right-small"></span> Your Town</a></li>
<li class="leaf item-wrapper-level-2 item-1839-wrap"><a href="/lists/all/health/all" class="item-1839 item-level-2"><span class="icon i-arrow-right-small"></span> Health</a></li>
<li class="leaf item-wrapper-level-2 item-1926-wrap"><a href="/lists/longboat-key/tributes/all" class="item-1926 item-level-2"><span class="icon i-arrow-right-small"></span> Tributes</a></li>
<li class="last leaf item-wrapper-level-2 item-2077-wrap"><a href="/lists/longboat-key/celebrations/all" class="item-2077 item-level-2"><span class="icon i-arrow-right-small"></span> Celebrations</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1137-wrap"><a href="/east-county" class="item-1137 item-level-1">East County</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1173-wrap"><a href="/lists/east-county/news/all" class="item-1173 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1174-wrap"><a href="/lists/east-county/opinion/all" class="item-1174 item-level-2"><span class="icon i-arrow-right-small"></span> Opinion</a></li>
<li class="leaf item-wrapper-level-2 item-1175-wrap"><a href="/lists/east-county/religion/all" class="item-1175 item-level-2"><span class="icon i-arrow-right-small"></span> Religion</a></li>
<li class="leaf item-wrapper-level-2 item-1177-wrap"><a href="/lists/east-county/cops-corner/all" class="item-1177 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1179-wrap"><a href="/lists/east-county/sports/all" class="item-1179 item-level-2"><span class="icon i-arrow-right-small"></span> Sports</a></li>
<li class="leaf item-wrapper-level-2 item-1267-wrap"><a href="/lists/east-county/neighbors/all" class="item-1267 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1180-wrap"><a href="/lists/east-county/schools/all" class="item-1180 item-level-2"><span class="icon i-arrow-right-small"></span> Schools</a></li>
<li class="leaf item-wrapper-level-2 item-1268-wrap"><a href="/lists/east-county/business/all" class="item-1268 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="leaf item-wrapper-level-2 item-1266-wrap"><a href="/lists/east-county/real-estate/all" class="item-1266 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
<li class="leaf item-wrapper-level-2 item-1269-wrap"><a href="/lists/east-county/your-town/all" class="item-1269 item-level-2"><span class="icon i-arrow-right-small"></span> Your Town</a></li>
<li class="leaf item-wrapper-level-2 item-1840-wrap"><a href="/lists/all/health/all" class="item-1840 item-level-2"><span class="icon i-arrow-right-small"></span> Health</a></li>
<li class="leaf item-wrapper-level-2 item-1698-wrap"><a href="/lists/east-county/lwr-life/all" class="item-1698 item-level-2"><span class="icon i-arrow-right-small"></span> LWR Life Magazine</a></li>
<li class="leaf item-wrapper-level-2 item-1927-wrap"><a href="/lists/east-county/tributes/all" class="item-1927 item-level-2"><span class="icon i-arrow-right-small"></span> Tributes</a></li>
<li class="last leaf item-wrapper-level-2 item-2078-wrap"><a href="/lists/east-county/celebrations/all" class="item-2078 item-level-2"><span class="icon i-arrow-right-small"></span> Celebrations</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1136-wrap"><a href="/sarasota" class="item-1136 item-level-1">Sarasota</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1149-wrap"><a href="/lists/sarasota/news/all" class="item-1149 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1150-wrap"><a href="/lists/sarasota/opinion/all" class="item-1150 item-level-2"><span class="icon i-arrow-right-small"></span> Opinion</a></li>
<li class="leaf item-wrapper-level-2 item-1276-wrap"><a href="/lists/sarasota/religion/all" class="item-1276 item-level-2"><span class="icon i-arrow-right-small"></span> Religion</a></li>
<li class="leaf item-wrapper-level-2 item-1145-wrap"><a href="/lists/sarasota/cops-corner/all" class="item-1145 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1272-wrap"><a href="/lists/sarasota/sports/all" class="item-1272 item-level-2"><span class="icon i-arrow-right-small"></span> Sports</a></li>
<li class="leaf item-wrapper-level-2 item-1148-wrap"><a href="/lists/sarasota/neighbors/all" class="item-1148 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1271-wrap"><a href="/lists/sarasota/schools/all" class="item-1271 item-level-2"><span class="icon i-arrow-right-small"></span> Schools</a></li>
<li class="leaf item-wrapper-level-2 item-1273-wrap"><a href="/lists/sarasota/business/all" class="item-1273 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="leaf item-wrapper-level-2 item-1274-wrap"><a href="/lists/sarasota/real-estate/all" class="item-1274 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
<li class="leaf item-wrapper-level-2 item-1275-wrap"><a href="/lists/sarasota/your-town/all" class="item-1275 item-level-2"><span class="icon i-arrow-right-small"></span> Your Town</a></li>
<li class="leaf item-wrapper-level-2 item-1841-wrap"><a href="/lists/all/health/all" class="item-1841 item-level-2"><span class="icon i-arrow-right-small"></span> Health</a></li>
<li class="leaf item-wrapper-level-2 item-1925-wrap"><a href="/lists/sarasota/tributes/all" class="item-1925 item-level-2"><span class="icon i-arrow-right-small"></span> Tributes</a></li>
<li class="last leaf item-wrapper-level-2 item-2079-wrap"><a href="/lists/sarasota/celebrations/all" class="item-2079 item-level-2"><span class="icon i-arrow-right-small"></span> Celebrations</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1032-wrap"><a href="/siesta-key" class="item-1032 item-level-1">Siesta Key</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1160-wrap"><a href="/lists/siesta-key/news/all" class="item-1160 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1277-wrap"><a href="/lists/siesta-key/religion/all" class="item-1277 item-level-2"><span class="icon i-arrow-right-small"></span> Religion</a></li>
<li class="leaf item-wrapper-level-2 item-1162-wrap"><a href="/lists/siesta-key/neighbors/all" class="item-1162 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1280-wrap"><a href="/lists/sarasota/real-estate/all" class="item-1280 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
<li class="leaf item-wrapper-level-2 item-1281-wrap"><a href="/lists/siesta-key/your-town/all" class="item-1281 item-level-2"><span class="icon i-arrow-right-small"></span> Your Town</a></li>
<li class="leaf item-wrapper-level-2 item-1842-wrap"><a href="/lists/all/health/all" class="item-1842 item-level-2"><span class="icon i-arrow-right-small"></span> Health</a></li>
<li class="leaf item-wrapper-level-2 item-1928-wrap"><a href="/lists/siesta-key/tributes/all" class="item-1928 item-level-2"><span class="icon i-arrow-right-small"></span> Tributes</a></li>
<li class="last leaf item-wrapper-level-2 item-2080-wrap"><a href="/lists/siesta-key/celebrations/all" class="item-2080 item-level-2"><span class="icon i-arrow-right-small"></span> Celebrations</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1284-wrap"><a href="/arts-and-entertainment" class="item-1284 item-level-1">Arts & Entertainment</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1855-wrap"><a href="/lists/arts-and-entertainment/eat-and-drink/all" class="item-1855 item-level-2"><span class="icon i-arrow-right-small"></span> Eat & Drink</a></li>
<li class="leaf item-wrapper-level-2 item-1476-wrap"><a href="/lists/arts-and-entertainment/music/all" class="item-1476 item-level-2"><span class="icon i-arrow-right-small"></span> Music</a></li>
<li class="leaf item-wrapper-level-2 item-1478-wrap"><a href="/lists/arts-and-entertainment/visual-art/all" class="item-1478 item-level-2"><span class="icon i-arrow-right-small"></span> Visual Art</a></li>
<li class="leaf item-wrapper-level-2 item-1479-wrap"><a href="/lists/arts-and-entertainment/performing-art/all" class="item-1479 item-level-2"><span class="icon i-arrow-right-small"></span> Performing Art</a></li>
<li class="leaf item-wrapper-level-2 item-1480-wrap"><a href="/lists/arts-and-entertainment/this-week/all" class="item-1480 item-level-2"><span class="icon i-arrow-right-small"></span> This Week</a></li>
<li class="leaf item-wrapper-level-2 item-1481-wrap"><a href="/photo-galleries/arts-and-entertainment/all" class="item-1481 item-level-2"><span class="icon i-arrow-right-small"></span> Photos</a></li>
<li class="leaf item-wrapper-level-2 item-1482-wrap"><a href="/videos/arts-and-entertainment/all" class="item-1482 item-level-2"><span class="icon i-arrow-right-small"></span> Videos</a></li>
<li class="leaf item-wrapper-level-2 item-1483-wrap"><a href="/lists/arts-and-entertainment/reviews/all" class="item-1483 item-level-2"><span class="icon i-arrow-right-small"></span> Reviews</a></li>
<li class="last leaf item-wrapper-level-2 item-1875-wrap"><a href="/arts-and-entertainment/calendar" class="item-1875 item-level-2"><span class="icon i-arrow-right-small"></span> A & E Calendar</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1141-wrap"><a href="/black-tie" class="item-1141 item-level-1">Black Tie</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1489-wrap"><a href="/blacktieapp" class="item-1489 item-level-2"><span class="icon i-arrow-right-small"></span> Social Calendar</a></li>
<li class="leaf item-wrapper-level-2 item-1854-wrap"><a href="/lists/black-tie/black-tie-and-tales/all" class="item-1854 item-level-2"><span class="icon i-arrow-right-small"></span> Black Tie & Tales</a></li>
<li class="leaf item-wrapper-level-2 item-1936-wrap"><a href="/lists/black-tie/style/all" class="item-1936 item-level-2"><span class="icon i-arrow-right-small"></span> Style</a></li>
<li class="leaf item-wrapper-level-2 item-1918-wrap"><a href="/lists/black-tie/familiar-faces/all" class="item-1918 item-level-2"><span class="icon i-arrow-right-small"></span> Familiar Faces</a></li>
<li class="leaf item-wrapper-level-2 item-1493-wrap"><a href="/lists/black-tie/just-married/all" class="item-1493 item-level-2"><span class="icon i-arrow-right-small"></span> Just Married</a></li>
<li class="last leaf item-wrapper-level-2 item-1697-wrap"><a href="/photo-galleries/black-tie/all" class="item-1697 item-level-2"><span class="icon i-arrow-right-small"></span> Photos</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1255-wrap"><a href="/photo-galleries/all/all" class="item-1255 item-level-1">Photos</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1903-wrap"><a href="/photos" class="item-1903 item-level-2"><span class="icon i-arrow-right-small"></span> Search Photos</a></li>
<li class="leaf item-wrapper-level-2 item-2087-wrap"><a href="/photo-gallery/2019-its-read-everywhere-submissions" class="item-2087 item-level-2"><span class="icon i-arrow-right-small"></span> It's Read Everywhere</a></li>
<li class="last leaf item-wrapper-level-2 item-2088-wrap"><a href="/photo-gallery/2019-weather-photo-contest-submissions" class="item-2088 item-level-2"><span class="icon i-arrow-right-small"></span> Weather & Nature</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1929-wrap"><a href="/lists/all/tributes/all" class="item-1929 item-level-1">Tributes / Obits</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1931-wrap"><a href="/lists/all/tributes/all" class="item-1931 item-level-2"><span class="icon i-arrow-right-small"></span> View All Tributes</a></li>
<li class="last leaf item-wrapper-level-2 item-1930-wrap"><a href="/tributes" class="item-1930 item-level-2"><span class="icon i-arrow-right-small"></span> Submit a Tribute / Obit</a></li>
</ul></li>
<li class="last expanded item-wrapper-level-1 item-2082-wrap"><a href="/lists/all/celebrations/all" class="item-2082 item-level-1">Celebrations</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-2083-wrap"><a href="/lists/all/celebrations/all" class="item-2083 item-level-2"><span class="icon i-arrow-right-small"></span> View All Celebrations</a></li>
<li class="last leaf item-wrapper-level-2 item-2084-wrap"><a href="/celebrations" class="item-2084 item-level-2"><span class="icon i-arrow-right-small"></span> Submit a Celebration</a></li>
</ul></li>
</ul>        </nav>
      </div>

      <div class="header-search">
        <span class="icon close-icon"></span>
        <form action="/article/longboat-key-mayor-writes-governor-on-covid-19-vaccines" method="post" id="search-block-form" accept-charset="UTF-8">
  <h2 class="element-invisible">Search form</h2>

<div>
  <label class="element-invisible" for="edit-search-block-form--2">Search</label>
 <input title="Enter the terms you wish to search for." placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="30" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" /></div><input type="hidden" name="form_build_id" value="form-9AIp1o7yMwR7icoIG3bdoXRCsSdTajvtPAJdBoYruwg" />
<input type="hidden" name="form_id" value="search_block_form" />
</form>      </div>
    </div>
  </div>

</div>
  </header>

  <div id="header_ad" class="advert-bar advert-bar--header bg--mild-grey">
    <div class="advert-wrapper">
      <div id="dfp-ad-header-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-header" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-header");
      });
  </script>
</div>
</div>    </div>
  </div>

<div class="page-wrapper">

      
      
      
      
  



<main class="section overflow-sticky">
  <div class="container large">
    <div class="col-2-3 page-content">
      <article about="/article/longboat-key-mayor-writes-governor-on-covid-19-vaccines" typeof="sioc:Item foaf:Document" class="article">

      
                        <div class="module--overlay-content red large has--image">
              <span class="type-label theme--bg theme--text section-title">




  News


</span>
            
                          <figure class="basic_article has--tooltip" tooltip-position="follow" data-tooltip="Longboat Key Mayor Ken Schneier wrote a letter to Gov. Ron DeSantis on Wednesday.">
                




  <img class="image full" typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/324107_standard.jpeg?itok=jpg4GGCJ" width="870" height="580" title="Longboat Key Mayor Ken Schneier wrote a letter to Gov. Ron DeSantis on Wednesday." />


              </figure>
            
            <div class="content">
              <div class="inner theme--bg">

                <div class="slide-out">
                  <div class="meta theme--text">
                    <span class="category">




  Longboat Key


</span>

                                          <span class="publish-time right">Thursday, Jan. 21, 2021




  <span class="date-display-interval"><em class="placeholder">7 hours</em> ago</span>


</span>
                    
                  </div>
                  <h1 class="title theme--text">Longboat Key mayor writes governor on COVID-19 vaccines</h1>
                                      <!-- <a href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/article/longboat-key-mayor-writes-governor-on-covid-19-vaccines&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/324107_standard.jpeg%3Fitok%3D2kgeKTme&notes=https%3A//d2rxg8fr1htsv9.cloudfront.net/photo/84281/6009e543afa94/original.JPG">Buy this Photo</a> -->
                                  </div>

              </div> <!-- inner -->
            </div> <!-- content -->
          </div>

        
        <div class="overflow-sticky">
                              <div class="sticky-container">
           <div class="article-social-bar sticky bg--lightest-grey" data-margin="nav" data-position="absolute">
              <span class="label text--red">Share</span>
              <ul class="social-icons">
                              <li>
                  <a href="#" class="link social-share" onclick="customFBShare(); return false;"><span class="icon facebook-icon"></span></a>
                                  </li>
                                            <li>
                  <a href="# " data-social="{&quot;type&quot;:&quot;twitter&quot;,&quot;url&quot;:&quot;https:\/\/www.yourobserver.com\/article\/longboat-key-mayor-writes-governor-on-covid-19-vaccines&quot;,&quot;text&quot;:&quot;Longboat Key mayor writes governor on COVID-19 vaccines&quot;}" class="link social-share"><span class="icon twitter-icon"></span></a>                </li>
                              <li>
                  <a href="/cdn-cgi/l/email-protection#98a7beebedfaf2fdfbeca5d7faebfdeaeefdeabdaaa8d5fdfcf1f9bdaaa8dfeaf7ede8bdaaa8b5bdaaa8d4f7f6fffaf7f9ecb8d3fde1b8f5f9e1f7eab8efeaf1ecfdebb8fff7eefdeaf6f7eab8f7f6b8dbd7ced1dcb5a9a1b8eef9fbfbf1f6fdebbefaf7fce1a5f0ecece8eba2b7b7efefefb6e1f7edeaf7faebfdeaeefdeab6fbf7f5b7f9eaecf1fbf4fdb7f4f7f6fffaf7f9ecb5f3fde1b5f5f9e1f7eab5efeaf1ecfdebb5fff7eefdeaf6f7eab5f7f6b5fbf7eef1fcb5a9a1b5eef9fbfbf1f6fdeb" target="_top" class="" title="Email This Page">
                    <span class="icon mail-icon"></span>
                  </a>
                </li>
              </ul>
              <a id="ps_disqus" href="#disqus_thread" class="comments right scrollto" data-scroll-target="disqus"></a>
           </div>
          </div>

                      <h6 class="dek left-margin">




  The letter asks the governor to prioritize distributing the vaccine to the most vulnerable populations.


</h6>
          
                                    




  <div class="author left-margin">
	by: 
	<a href="/articles/author/mark-bergin" title="See All Articles by Mark Bergin" class="text--red">
		




  Mark Bergin


	</a>
	<span>




  Staff Writer


</span>
</div>



                      


          <div id="content--wrapper" class="content--wrapper">
            <div class="p402_premium">
              




  <p>Longboat Key Mayor Ken Schneier wrote a letter to Gov. Ron DeSantis on behalf of the town about the state’s COVID-19 vaccine distribution, urging greater consideration for older residents&nbsp;</p><p>Schneier <a href="https://www.scribd.com/document/491634974/Jan-20-2021-Mayor-Ken-Schneier-s-letter-to-Gov-Ron-DeSantis-on-COVID-19-vaccine-priority-by-age">sent the letter</a> to the governor’s office on Wednesday.</p><p>“The state’s mortality data related to COVID-19 shows the more elderly,&nbsp;have more serious illness, and higher death rate, as they age into their 70s, 80s and beyond,” Schneier wrote. “We urge you to allow the county FDOH officials to place a higher priority on vaccinating by age, instead of a random lottery selection, and other first-come, first-served registration systems being used.”</p><p>As of Wednesday afternoon, <a href="http://ww11.doh.state.fl.us/comm/_partners/covid19_report_archive/cases-monitoring-and-pui-information/state-report/state_reports_latest.pdf">Florida Department of Health data shows</a> of the state’s 24,578 COVID-19-related deaths, 20,422 of them are people aged 65 and older. Some 15,190 of those deaths are among people 75 and older.</p><p>About 69% of the town’s 6,700 full-time residents are older than 65 years old. The town’s population increases to about 25,000 during snowbird season.</p><aside class="content--sidebar half-size inline-left"><h6>Signing up</h6><p>&nbsp;</p><p>The town of Longboat Key has posted on its website information on signing up for COVID-19 vaccines and a way to fill out the necessary paperwork ahead of time. Visit: <a href="https://www.longboatkey.org/i-want-to/view/covid-19/">longboatkey.org/i-want-to/view/covid-19/</a></p><p><strong>In Sarasota County&nbsp;</strong></p><p><strong>How to do it:</strong> Use the website <a href="http://sarasota.floridahealth.gov/">sarasota.floridahealth.gov</a> and&nbsp;tap&nbsp;on “CLICK HERE to go to the New Everbridge Registration System for COVID-19 Vaccinations in Sarasota County.” &nbsp;Individuals will also be able to register over the phone by calling 941-861-8297 or by using the Everbridge smartphone app.For information:&nbsp;861-2900.</p><p><strong>Where:</strong>&nbsp;On Thursday and Friday, the Sarasota County Department of Health will set up a&nbsp;by-appointment drive-through clinic Twin Lakes Park at 6700 Clark Road. The Sarasota County Department of Health is not planning to use&nbsp;its 2200 Ringling Blvd.&nbsp;location for second-dose vaccinations. New and additional sites are possible.</p><p><strong>In Manatee County&nbsp;</strong></p><p><strong>How to do it:</strong> Use the website&nbsp;<a href="http://vax.mymanatee.org">vax.mymanatee.org</a>. Click or tap “REGISTER NOW.” Once someone registers, they are entered into the county’s COVID-19 vaccination standby pool for the first dose of the COVID-19 vaccine, as vaccinations become available. For information: 748-0747.</p><p><strong>Where:</strong>&nbsp;Bennett Park, 400 Cypress Creek Blvd. New and additional sites are possible.&nbsp;</p><p><strong>Learn when appointments open</strong></p><p>People wanting to receive alerts when Sarasota County has vaccines available can text “SRQCOVID19” to 888777 (six digits). Manatee County offers a similar text service by sending “ManateeReady” to 888777 (six digits).</p><p>&nbsp;</p></aside><p>State data indicates 177 cases on Longboat Key since the pandemic began.&nbsp;</p><p>“Our demographic also makes up the oldest demographic by community, in Sarasota and Manatee counties combined,” Schneier wrote. “This demographic is considered as the most susceptible to severe illness and death from the COVID-19 virus.”</p><p>Schneier has also asked the governor’s office about expanding vaccination locations to the Publix at 525 Bay Isles Parkway. The mayor said many Longboat Key residents will have to drive as far as 20 miles to the closest vaccination site, which could also increase the likelihood of someone’s exposure to coronavirus. Manatee County has offered vaccines at Tom Bennett Park, adjacent to Interstate 75&nbsp;in Bradenton. Sarasota County has performed vaccination at the county health department building in downtown Sarasota, and this weekend at Twin Lakes Park, east of Interstate 75 on State Road 72.&nbsp;&nbsp;</p><p>Town Manager Tom Harmer confirmed the Publix in Longboat Key is “interested and willing” to distribute the vaccine.</p><p>The town has also proposed to set up a vaccination site at the Temple Beth Israel at 567 Bay Isles Road or at the CVS Pharmacy at 505 Bay Isles Parkway.</p><p>Harmer said Sarasota County is in the process of setting up another vaccination site in the south Venice or North Port area.</p><p>At-Large Commissioner BJ Bishop was critical of the location of Sarasota County’s vaccination sites.</p><p>“My one concern continues to be we have older people who should not be driving off the island, and I can’t think of two worse locations than east of [Interstate] 75 and south of Venice to direct our population to for these early shots,” Bishop said. “It just defies logic to me that those are the opportunities made available to our most vulnerable population.”</p><p>Initially, the Centers for Disease Control and Prevention recommended distributing the vaccines to people aged 75 and older. DeSantis decided Florida would distribute them to people 65 and older.</p><p>The governor’s decision <a href="/article/longboat-aims-for-covid-19-vaccine-site">prompted criticism from Longboat Key commissioners</a> earlier this month. However, the CDC has since lowered its recommendation to 65.</p><p>“It is our express desire to have vaccines for our most vulnerable citizens,” Schneier wrote.</p><p>Schneier’s letter comes the same day Sarasota County launched a new registration process for COVID-19 vaccination appointments. The new process uses the Everbridge platform and allows residents to add their names to a waiting list for available appointment slots.</p><p>On Wednesday, DeSantis also announced only full-time and part-time residents of Florida are eligible to receive the vaccination through the state. The decision is expected to stop people traveling to Florida just to receive the vaccine.</p><p>Two weeks ago, DeSantis commended Manatee County's efforts to deliver COVID-19 vaccinations to seniors on a visit to Tom Bennett Park in Bradenton. Manatee County uses a preregistration pool process.</p><p>Longboat Key is planning to conduct is public meetings using a hybrid format through February. The town’s mandatory mask ordinance runs through March 31.</p><p><iframe class="scribd_iframe_embed" data-aspect-ratio="0.7727272727272727" data-auto-height="false" frameborder="0" height="600" id="doc_47599" scrolling="no" src="https://www.scribd.com/embeds/491634974/content?start_page=1&amp;view_mode=scroll&amp;access_key=key-mowVrt9Cl1f9dcC2xpg6" title=" Mayor Ken Schneier&#039;s letter to Gov. Ron DeSantis on COVID-19 vaccine priority by age" width="100%"></iframe></p>


            </div>
            <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
              try { _402_Show(); } catch(e) {}
            </script>
          </div>
        </div>

                                          <div class="author-box bg--lightest-grey">
  <div class="header">
  	    	<a href="/mark-bergin">
    	    <figure class="profile-pic">




  <img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/people_profile/public/_mbergin.jpg?itok=1y-wOFyx" width="300" height="300" />


</figure>
	    <h5 class="gamma author-name">The Author: 




  Mark Bergin


</h5>
	      	</a>
      </div>
  <div class="content--wrapper">
    <p>




  <p></p><p>Mark Bergin is the Longboat Key Town Hall reporter for the Observer. He has previously worked as a senior digital producer at WTSP, the CBS affiliate in St. Petersburg. Mark is a graduate of the University of Missouri and grew up in the Chicagoland area.</p>


</p>
  </div>

   <div class="article-social-bar sticky bg--lightest-grey" data-margin="nav" data-position="absolute">
      <ul class="social-icons">
              <li>
          <a href="#" class="link social-share" onclick="customFBShare(); return false;"><span class="icon facebook-icon"></span></a>
                  </li>
                    <li>
          <a href="https://twitter.com/mdbergin" target="_blank" class="link"><span class="icon twitter-icon"></span></a>        </li>
                    <li>
          <a href="/cdn-cgi/l/email-protection#95f8f7f0e7f2fcfbd5ecfae0e7faf7e6f0e7e3f0e7bbf6faf8" target="_top" class="" title="Email This Page">
            <span class="icon mail-icon"></span>
          </a>
        </li>
            </ul>
   </div>

      <a class="view-in-cws" href="/articles/author/mark-bergin" title="See All Articles by Mark">
      See All Articles by Mark    </a>
  </div>                  
        

      </article>

              <div class="pagination-wrapper">

                      <a href="/article/condo-termination-agreement-paves-way-for-st-regis-next-step" class="col-1-2 bg--lightest-grey pagination-item prev">
              <div class="label left-icon">
                <span class="icon line-arrow-left-long-icon"></span>
                <span class="text">Prev Article</span>
              </div>
              <h6 class="title">Condo termination agreement paves way for St. Regis' next step</h6>
            </a>
          
          
        </div>
      
    </div> <!-- col-2-3 -->

    <div class="col-1-3 sidebar">
      
      

              <div id="ad_wrapper_t" class="advert-sidebar" data-margin="80" data-position="absolute" data-append="">
          <div id="ad_wrapper_top">
            <div id="dfp-ad-half_page-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-half_page" class="dfp-tag-wrapper">
    <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-half_page");
      });
  </script>
</div>
</div>                              <div id="dfp-ad-stacked_top-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-stacked_top" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-stacked_top");
      });
  </script>
</div>
</div>                        </div>
        </div>

        <div id="email-sign-up" class="side--bar-signup">
          <div class="module signup">
            <h6 class="section-title text--red">sign up to receive our news in your inbox!</h6>
                          <form class="mailchimp-signup-subscribe-form" action="//cdn.digitalobservermedia.com/yourobserver.com/email-subscribe/" method="get" target="_blank">
              <div class="form-required">
                <label class="required" for="edit-mergevars-email">Email Address</label>
                <input type="text" id="edit-mergevars-email" name="email" value="" size="30" maxlength="128" required="">
              </div>
              <input type="submit" id="edit-submit--2" value="Submit">
            </form>                      </div>
        </div>

        <div class="section pad">
            <ul id="most_popular" data-margin="80" data-position="absolute" data-append=""></ul>
        </div>
      
      <div class="section pad sticky-container">
        <div id="ad_wrapper_b" class="advert-sidebar sticky" data-margin="80" data-position="absolute" data-append="">
          <div id="ad_wrapper_bottom">
            <div id="dfp-ad-stacked_bottom-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-stacked_bottom" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-stacked_bottom");
      });
  </script>
</div>
</div>                        	<div id="dfp-ad-stacked_bottom_2-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-stacked_bottom_2" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-stacked_bottom_2");
      });
  </script>
</div>
</div>          	          </div>
        </div>
      </div>

    </div>

  </div><!-- container -->

            <a class="pagination-item prev fixed" href="/article/condo-termination-agreement-paves-way-for-st-regis-next-step">
          <span class="icon arrow-left-icon"></span>
          <span class="text">Prev Article</span>
      </a>
          
      

      <section class="section pad bg--lighter-grey">
      <div class="container">

        <header class="section-title">
          <h2 class="title delta bg--red">Related Stories</h2>
        </header>

        <div class="col-2-3">
          <div id="related_stories" class="section teasers"></div>
        </div>

                  <div class="col-2-3">
            <div id="rc-widget-e1c45c" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="115384"></div>
            <script type="text/javascript" src="//assets.revcontent.com/master/delivery.js" defer="defer"></script>
          </div>
        
        <div class="col-2-3 disqus--wrapper" data-scroll-anchor="disqus">
          <div id="disqus_thread"><noscript><p><a href="http://yourobserver.disqus.com/?url=https%3A%2F%2Fwww.yourobserver.com%2Farticle%2Flongboat-key-mayor-writes-governor-on-covid-19-vaccines">View the discussion thread.</a></p></noscript></div>        </div>

      </div>
    </section>
  
  <div id="mobile_ad_container_top" class="ad-hide">
    <div id="mobile_ad_placement_top" class="advert-sidebar bg--mild-grey ad-hide" data-margin="80" data-position="absolute" data-append="">

    </div>
  </div>

  <div id="mobile_ad_container_bottom" class="ad-hide">
    <div id="mobile_ad_placement_bottom" class="advert-sidebar bg--mild-grey ad-hide" data-margin="80" data-position="absolute" data-append="">

    </div>
  </div>

</main>

      

      
    
  
</div><!-- /page-->

<div id="sticky-footer">
  <div id="dfp-ad-sticky_footer-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-sticky_footer" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-sticky_footer");
      });
  </script>
</div>
</div></div>

  

<footer class="site--footer">

      <div id="footer_ad" class="advert-bar advert-bar--footer bg--mild-grey">
      <div class="advert-wrapper">
        <div id="dfp-ad-footer-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-footer" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-footer");
      });
  </script>
</div>
</div>      </div>
    </div>
  
  <div class="footer-nav">
    <div class="section bg--lightest-grey">
      <ul class="links"><li class="first leaf item-wrapper-level-1 item-1202-wrap"><a href="/about-us" class="item-1202 item-level-1">About</a></li>
<li class="leaf item-wrapper-level-1 item-1204-wrap"><a href="/contact-us" class="item-1204 item-level-1">Contact Us</a></li>
<li class="leaf item-wrapper-level-1 item-1205-wrap"><a href="http://classifieds.yourobserver.com/" class="item-1205 item-level-1">Classifieds</a></li>
<li class="leaf item-wrapper-level-1 item-1314-wrap"><a href="/advertise" title="Advertise" class="item-1314 item-level-1">Advertise</a></li>
<li class="leaf item-wrapper-level-1 item-1207-wrap"><a href="/rack-locations" class="item-1207 item-level-1">Rack Locations</a></li>
<li class="leaf item-wrapper-level-1 item-1208-wrap"><a href="/subscribe" class="item-1208 item-level-1">Subscribe</a></li>
<li class="leaf item-wrapper-level-1 item-1210-wrap"><a href="/jobs" class="item-1210 item-level-1">Jobs</a></li>
<li class="leaf item-wrapper-level-1 item-1319-wrap"><a href="/sponsorships" class="item-1319 item-level-1">Sponsorships</a></li>
<li class="last leaf item-wrapper-level-1 item-1242-wrap"><a href="/privacy-policy" class="item-1242 item-level-1">Privacy Policy</a></li>
</ul>    </div>
  </div>

  <div class="section contact-social-signup bg--lighter-grey">
    <div class="col-2-3 module">

      <div class="col-1-2 module contact">
        <h4 class="section-title text--red">Contact Us</h4>
        <img class="logo" src="/sites/all/themes/yourobserver/images/logos/logo-gray.svg" alt="Your Observer Logo" />
        <div class="grid">
          <div class="col-1-2">
            1970 Main Street <br>
                          Third Floor<br>
                        Sarasota, FL&nbsp;34236          </div>
          <div class="col-1-2">
            <b>Phone:</b> <a href="tel:941-366-3468">941-366-3468</a><br>
            <b>Fax:</b>   <a href="tel:941-362-4808">941-362-4808</a><br>
            <b>Email:</b> <a href="/cdn-cgi/l/email-protection#89afe7ebfaf9b2">&nbsp;</a>
          </div>
        </div>
      </div>

      <div class="col-1-2 module socialize">
        <h4 class="section-title text--red">Socialize With Us</h4>
        <div class="grid">

        	          	<a href="https://www.facebook.com/ObserverGroup" class="icon facebook-icon col-1-6" target="_blank"></a>
          
                    	<a href="https://twitter.com/ObserverGroup" class="icon twitter-icon col-1-6" target="_blank"></a>
          
                      <a href="https://www.instagram.com/observergroup/" class="icon instagram-icon col-1-6" target="_blank"></a>
          
          
                    	<a href="https://www.youtube.com/user/YourObserverVideo" class="icon youtube-icon col-1-6" target="_blank"></a>
          
                    	<a href="https://www.linkedin.com/company/the-observer-group?trk=company_logo" class="icon linkedin-icon col-1-6" target="_blank"></a>
          
          
        </div>
      </div>
    </div>

    <div class="col-1-3 module signup">
      <h4 class="section-title text--red">sign up to receive our news in your inbox!</h4>
              <form class="mailchimp-signup-subscribe-form" action="//cdn.digitalobservermedia.com/yourobserver.com/email-subscribe/" method="get" target="_blank">
      <div class="form-required">
        <label class="required" for="edit-mergevars-email">Email Address</label>
        <input type="text" id="edit-mergevars-email" name="email" value="" size="30" maxlength="128" required="">
      </div>
      <input type="submit" id="edit-submit--2" value="Submit">
    </form>                </div>
  </div>

  <div class="section bg--dark-grey">
    <div class="col-4-7 module sister-sites">
      <h4 class="section-title">Our Sister Sites</h4>

                    
                      <div class="grid">
                      
          <a href="http://www.businessobserverfl.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/business.png?itok=ulxToCJ3" alt="" /></a>
                        
          
          <a href="http://www.palmcoastobserver.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/palmcoast.png?itok=9DShShL7" alt="" /></a>
                                  </div>
                        
                      <div class="grid">
                      
          <a href="http://www.orangeobserver.com" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/orange.png?itok=ky46z5ix" alt="" /></a>
                        
          
          <a href="http://www.ormondbeachobserver.com" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/ormond.png?itok=d1OhVE0m" alt="" /></a>
                                  </div>
                        
                      <div class="grid">
                      
          <a href="https://www.portorangeobserver.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/port.png?itok=wZRn9KmU" alt="" /></a>
                        
          
          <a href="https://www.jaxdailyrecord.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/jax.png?itok=vhKvdwtA" alt="" /></a>
                                  </div>
                      
      
    </div>

    <div class="col-3-7 right module other-pubs">
      <h4 class="section-title">Other Publications</h4>
      <div class="inner">
                	<img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/other_publications_200x140/public/media/other-pubs_0_0.png?itok=7SbC7L-C" alt="" />                <p>
        	        		Browse a digital collection of our other publications, magazines and special sections such as Season Magazine, Health Matters, Holiday Gift Guide and more .        	        </p>
        <a href="/e-editions" class="button">VIEW ALL<span class="cta-right"></span></a>      </div>
    </div>
  </div>

  <div class="copy-bar">
    <span class="text">Copyright &copy;&nbsp;2021&nbsp;Observer Media Group, Inc., All Rights Reserved</span>
    <a class="right" href="http://www.atlargeinc.com" target="_blank"><img src="/sites/all/modules/features/tog_site_wide/theme/atlarge-logo.svg" alt="Site created by atLarge inc."></a>
  </div>

</footer>

<!-- The Modal -->
<div id="myModal" class="modal">

  <!-- Modal content -->
  <div class="modal-content">
    <span class="close">&times;</span>
    <div class="logo-wrapper">
      <img class="logo" src="/sites/all/themes/yourobserver/images/logos/logo-gray.svg" alt="Your Observer Logo" />
    </div>
    <h5 id="myModalHeader" class="section-title text--red">We've noticed you like reading articles on our site.</h5>
    <div id="#limit" class="related-modal-wrapper" style="position: relative; overflow: hidden;">
      <div id="related_stories_modal"></div>
    </div>
    <div class="modal-signup">
      <div id="secondary_header" class="module signup">
        <h6 class="section-title text--red">sign up to receive our news in your inbox!</h6>
                  <form class="mailchimp-signup-subscribe-form" action="//cdn.digitalobservermedia.com/yourobserver.com/email-subscribe/" method="get" target="_blank">
      <div class="form-required">
        <label class="required" for="edit-mergevars-email">Email Address</label>
        <input type="text" id="edit-mergevars-email" name="email" value="" size="30" maxlength="128" required="">
      </div>
      <input type="submit" id="edit-submit--2" value="Submit">
    </form>              </div>
    </div>
  </div>

</div>
  
  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="/sites/all/modules/custom/tog_most_popular/js/tog_most_popular_track.js?qnbc81"></script>
<script src="/sites/all/themes/yourobserver/scripts/dist/app.js?qnbc81"></script>
<script src="/sites/all/themes/yourobserver/scripts/ads.js?qnbc81"></script>
<script src="/sites/all/themes/yourobserver/scripts/block_buster.js?qnbc81"></script>
<script src="/sites/all/modules/custom/tog_most_popular/js/tog_most_popular.js?qnbc81"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_share.js?qnbc81"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_related.js?qnbc81"></script>
<script src="/sites/all/modules/features/tog_people/js/tog_people_stories.js?qnbc81"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_disqus.js?qnbc81"></script>
      <script type="application/ld+json">
      {"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.yourobserver.com\/article\/longboat-key-mayor-writes-governor-on-covid-19-vaccines"},"headline":"Longboat Key mayor writes governor on COVID-19 vaccines","image":{"@type":"ImageObject","url":"https:\/\/www.yourobserver.com\/sites\/default\/files\/styles\/sliders_and_planned_story_image_870x580\/public\/324107_standard.jpeg?itok=jpg4GGCJ","height":580,"width":870},"datePublished":"2021-01-21T14:30:00-05:00","dateModified":"2021-01-21T20:30:02-05:00","author":{"@type":"Person","name":"Mark Bergin"},"publisher":{"@type":"Organization","name":"Your Observer","logo":{"@type":"ImageObject","url":"https:\/\/www.yourobserver.com\/sites\/all\/themes\/yourobserver\/images\/logos\/logo-bright.png","width":323,"height":33}},"description":"The letter asks Gov. Ron DeSantis to prioritize distributing the vaccine to the most vulnerable populations."}    </script>
    <div id="adsense" style="position:absolute; top:10px; left:-999999px;">Advertisement</div>
  <div id="conversion_overlay" style="position: fixed; display: none; width: 100%; height: 100%;top: 0; left: 0;right: 0; bottom: 0; background-color: rgba(0,0,0,.9); z-index: 9999;"></div>
    </body>
</html>
