<!DOCTYPE html>

  <!--[if lt IE 7 ]><html class="no-js ie ie6 oldie" lang="en"> <![endif]-->
  <!--[if IE 7 ]><html class="no-js ie ie7 oldie" lang="en"> <![endif]-->
  <!--[if IE 8 ]><html class="no-js ie ie8 oldie" lang="en"> <![endif]-->
  <!--[if IE 9 ]><html class="no-js ie ie9" lang="en"> <![endif]-->
  <!--[if (gte IE 9)|!(IE)]><!--><html lang="en" class="loaded"> <!--<![endif]-->
  <head>
    <title>Lakewood Ranch dance company super charged to perform during Daytona 500 weekend | East County | Your Observer</title>

    <!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="google-site-verification" content="NhzK4FRO_M2NOv6dXIvbzW8cP7sCfyrssSGx8x1jWkU"/><meta property="fb:pages" content="288643121405"/><meta name="google-site-verification" content="NhzK4FRO_M2NOv6dXIvbzW8cP7sCfyrssSGx8x1jWkU"/><meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests"/><meta property="fb:app_id" content="949279485485509"/><link rel="amphtml" href="https://www.yourobserver.com/photo-gallery/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend?amp" />
<link rel="shortcut icon" href="https://www.yourobserver.com/sites/all/themes/yourobserver/favicon.ico" />
<script>dataLayer = [{"entityType":"node","entityBundle":"planned_story","entityId":"814201","entityLabel":"Lakewood Ranch dance company super charged to perform during Daytona 500 weekend","entityLanguage":"und","entityTnid":"0","entityVid":"814930","entityName":"admin","entityUid":"1","entityCreated":"1635791396","entityStatus":"1","entityTaxonomy":{"planned_story_type":{"2":"Photo Gallery"},"publication":{"7":"East County"},"planned_story_section":{"10":"News"}},"drupalLanguage":"en","userUid":0,"entityAuthor":"Jay Heater"}];</script>
<meta name="description" content="Art and Soul Dance Company of Lakewood Ranch receives an invitation to perform during Daytona 500 weekend." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.yourobserver.com/photo-gallery/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend" />
<link rel="shortlink" href="https://www.yourobserver.com/node/814201" />
<meta property="og:site_name" content="Your Observer" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Lakewood Ranch dance company super charged to perform during Daytona 500 weekend | East County | Your Observer" />
<meta property="og:url" content="https://www.yourobserver.com/photo-gallery/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend" />
<meta property="og:description" content="Art and Soul Dance Company of Lakewood Ranch receives an invitation to perform during Daytona 500 weekend." />
<meta property="og:updated_time" content="2021-11-05T11:28:18-04:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.yourobserver.com/photo-gallery/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend" />
<meta name="twitter:title" content="Lakewood Ranch dance company super charged to perform during Daytona" />
<meta name="twitter:description" content="Art and Soul Dance Company of Lakewood Ranch receives an invitation to perform during Daytona 500 weekend." />
<meta property="article:published_time" content="2021-11-01T14:29:56-04:00" />
<meta property="article:modified_time" content="2021-11-05T11:28:18-04:00" />

    <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
    <meta name="google-site-verification" content="W5qEe1V8ciPqgo7dPyNIXQ-wHbIW1dBCGQ-dzCLvNgQ" />

    <meta http-equiv="cleartype" content="on">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

          <meta property="og:image" content="https://www.yourobserver.com/sites/default/files/360880_standard.jpeg" />
    
          <link rel="alternate" type="application/rss+xml" title="RSS Feed | Your Observer" href="https://www.yourobserver.com/article/rss/east-county/news" />    
    <link rel="shortcut icon" href="https://www.yourobserver.com/sites/all/themes/yourobserver/favicon.ico?v=1.3">
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-152x152.png">
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-144x144.png">
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-120x120.png">
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-114x114.png">
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-72x72.png">
<link rel="apple-touch-icon-precomposed" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-57x57.png">
    <link rel="stylesheet" href="https://www.yourobserver.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" />
<link rel="stylesheet" href="https://www.yourobserver.com/sites/default/files/css/css_LGPfSzKpPyt30S4DeUQesoVz1kT21vSiBb1TrW-1DyY.css" />
<link rel="stylesheet" href="https://www.yourobserver.com/sites/default/files/css/css_x5Fq5EzNWPdKouhe63RrWnm4QrcyFKzbSgRxOgqzC_I.css" />
<link rel="stylesheet" href="https://www.yourobserver.com/sites/default/files/css/css_47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU.css" />

    <!--[if lte IE 8]>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/respond.js"></script>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/selectivizr.js"></script>
    <![endif]-->
    <!--[if lt IE 9]>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/html5shiv.js"></script>
    <![endif]-->

    <script src="/sites/default/files/google_tag/google_tag.script.js?r23to1"></script>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.9/jquery.min.js'>\x3C/script>")</script>
<script src="/misc/jquery-extend-3.4.0.js?v=1.9.1"></script>
<script src="/misc/jquery-html-prefilter-3.5.0-backport.js?v=1.9.1"></script>
<script src="/misc/jquery.once.js?v=1.2"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="/misc/drupal.js?r23to1"></script>
<script>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</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([1018, 0], [[970, 66], [970, 90], [728, 90]])
  .addSize([0, 0], [320, 50])
  .build();
googletag.slots["footer"] = googletag.defineSlot("/30582678/OMG/yourobserver/east-county/news", [[970, 66], [320, 50], [970, 90], [728, 90]], "dfp-ad-footer")
  .addService(googletag.pubads())
  .setTargeting("pos", "btf")
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([1018, 0], [970, 250])
  .addSize([0, 0], [320, 100])
  .build();
googletag.slots["billboard"] = googletag.defineSlot("/30582678/OMG/yourobserver/east-county/news", [[970, 250], [320, 100]], "dfp-ad-billboard")
  .addService(googletag.pubads())
  .setTargeting("pos", "btf")
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([1018, 0], [[970, 66], [970, 90], [728, 90]])
  .addSize([0, 0], [320, 50])
  .build();
googletag.slots["header"] = googletag.defineSlot("/30582678/OMG/yourobserver/east-county/news", [[970, 66], [320, 50], [970, 90], [728, 90]], "dfp-ad-header")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf")
  .defineSizeMapping(mapping);</script>
<script>googletag.slots["photo_gallery"] = googletag.defineSlot("/30582678/OMG/yourobserver/east-county/news", [300, 250], "dfp-ad-photo_gallery")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf");</script>
<script>googletag.slots["stacked_top"] = googletag.defineSlot("/30582678/OMG/yourobserver/east-county/news", [300, 250], "dfp-ad-stacked_top")
  .addService(googletag.pubads())
  .setTargeting("pos", "stf");</script>
<script>googletag.slots["half_page"] = googletag.defineSlot("/30582678/OMG/yourobserver/east-county/news", [[300, 250], [300, 600]], "dfp-ad-half_page")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf");</script>
<script>googletag.slots["stacked_bottom"] = googletag.defineSlot("/30582678/OMG/yourobserver/east-county/news", [300, 250], "dfp-ad-stacked_bottom")
  .addService(googletag.pubads())
  .setTargeting("pos", "btf");</script>
<script>googletag.slots["stacked_bottom_2"] = googletag.defineSlot("/30582678/OMG/yourobserver/east-county/news", [300, 250], "dfp-ad-stacked_bottom_2")
  .addService(googletag.pubads())
  .setTargeting("pos", "btf");</script>
<script>googletag.slots["sticky_footer"] = googletag.defineOutOfPageSlot("/30582678/OMG/yourobserver/east-county/news", "dfp-ad-sticky_footer")
  .addService(googletag.pubads());</script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
  googletag.pubads().setTargeting("ob_paper", "East County");
  googletag.pubads().setTargeting("ob_section", "News");
  googletag.pubads().setTargeting("hostname", "www.yourobserver.com");
  googletag.pubads().setTargeting("url_arg_0", "photo-gallery");
  googletag.pubads().setTargeting("url_arg_1", "lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend");
  googletag.pubads().setTargeting("ob_type", "Photo Gallery");
  googletag.pubads().setTargeting("page-type", "Photo Gallery");
  googletag.pubads().setTargeting("page-type", "photo-gallery");
});

googletag.enableServices();</script>
<script src="/sites/all/modules/contrib/disqus/disqus.js?r23to1"></script>
<script src="/sites/all/modules/contrib/datalayer/datalayer.js?r23to1"></script>
<script src="/sites/all/themes/yourobserver/scripts/dist/modernizr.js?r23to1"></script>

    <!-- PICO -->
          <script>(function(p,i,c,o){var n=new Event("pico-init");i[p]=i[p]||function(){(i[p].queue=i[p].queue||[]).push(arguments)},i.document.addEventListener("pico-init",function(e){var t=i.Pico.getInstance(e,{publisherId:o,picoInit:n},i);t.handleQueueItems(i[p].queue),i[p]=function(){return t.handleQueueItems([arguments])}},!1);var e=i.document.createElement("script"),t=i.document.getElementsByTagName("script")[0];e.async=1,e.src=c,e.onload=function(e){return i.Pico.getInstance(e,{publisherId:o,picoInit:n},i)},t.parentNode.insertBefore(e,t)})("pico",window,"https://gadget.pico.tools/wrapper.min.js","86b567c3-3ce5-4d23-afb5-01fda140df57");</script>
    
  </head>

  <body class="not-front no-sidebars node-type-planned-story no--top-ad no--billboard-ad no--mid-leaderboard-ad no--footer-ad no--stacked-top no--stacked-bottom no--sponsored" >

  
  <a href="#content--wrapper" class="element-invisible element-focusable">
    Skip to main content  </a>

  
  <noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TK5NRZ" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript>
  

<!--  mobile--only mobile--hide -->
<div id="data_policy" class="data-policy-container bg--mild-grey" style="padding:20px 0 20px 0; width: 100%; height: auto; display: none;">
  <div style="width: 85%; height: auto; margin: 0 auto;">
    <p style="margin-bottom: 10px;"><span class="mobile--hide">The Observer Media Group Inc. respects your privacy and values the relationship we have with you. We use technology to collect information that helps us enhance your experience and our products and services. The cookies we use help us understand what information and advertising are most useful and valuable.</span> Please take a moment to review our <a href="/cookie-policy">Cookie Policy</a> and <a href="/privacy-policy">Privacy Policy</a>. By clicking "Accept," you agree to our use of cookies and similar technologies.</p>
    <div class="accept-privacy-button" style="margin:auto; width: 100px; padding: 5px; border-radius: 5px;background: #9F0014; text-align: center;">
      <a id="privacy_button" href="#" style="color: white;">Accept</a>
    </div>
  </div>
</div>

  <div id="billboard_ad" class="advert-bar--billboard">
    <div class="advert-wrapper">
      <div id="dfp-ad-billboard-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-billboard" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-billboard");
      });
  </script>
</div>
</div>    </div>
  </div>

  <header class="main-header" role="banner">
      <div class="site--header bg--red">

  <div class="nav--top">
    <a href="/" title="Home" rel="home" class="logo">
      <img src="/sites/all/themes/yourobserver/images/logos/logo-bright.svg" alt="Home" />
    </a>
    <div class="right-nav right">
      <div class="secondary-nav">
      	<ul class="links"><li class="first leaf item-wrapper-level-1 item-2107-wrap"><a href="https://yourobserver.com/spotlight/affordable-housing" class="item-2107 item-level-1">Affordable Housing</a></li>
<li class="leaf item-wrapper-level-1 item-2102-wrap"><a href="https://www.yourobserver.com/spotlight/development" class="item-2102 item-level-1">Development</a></li>
<li class="leaf item-wrapper-level-1 item-1924-wrap"><a href="/lists/all/health/all" class="item-1924 item-level-1">Health</a></li>
<li class="leaf item-wrapper-level-1 item-1183-wrap"><a href="/lists/all/real-estate/all" class="item-1183 item-level-1">Real Estate</a></li>
<li class="leaf item-wrapper-level-1 item-1198-wrap"><a href="/redpages" class="item-1198 item-level-1">RedPages</a></li>
<li class="collapsed item-wrapper-level-1 item-1199-wrap"><a href="/contests" class="item-1199 item-level-1">Contests</a></li>
<li class="leaf item-wrapper-level-1 item-1184-wrap"><a href="/e-editions?publication=220" class="item-1184 item-level-1">E-Newspaper</a></li>
<li class="leaf item-wrapper-level-1 item-2104-wrap"><a href="/" class="PicoSignal PicoMyObserver PicoManagePayment item-2104 item-level-1">myObserver</a></li>
<li class="last leaf item-wrapper-level-1 item-2105-wrap"><a href="/" class="PicoSignal PicoLogin PicoPopup_ee9a2pdaqx item-2105 item-level-1">Register / Login</a></li>
</ul>      </div>
      <div id="weather" class="header-module--weather bg--light-red">
        <span class="icon rainy-icon "></span><span class="temp">69</span>
        <span class="date right"></span>
      </div>
    </div>

    <span class="mobile-trigger search mobile--only" data-class="search">
      <span class="icon search-icon"></span>
    </span>
    <span class="mobile-trigger close-search mobile--only" data-class="search">
      <span class="icon close-icon"></span>
    </span>
    <div class="mobile-trigger menu mobile--only" data-class="menu">
      <span class="icon menu-icon"></span>
    </div>

    <div class="header-search mobile--only">
      <form action="/photo-gallery/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend" method="post" id="search-block-form" accept-charset="UTF-8">
  <h2 class="element-invisible">Search form</h2>

<div>
  <label class="element-invisible" for="edit-search-block-form--2">Search</label>
 <input title="Enter the terms you wish to search for." placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="30" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" /></div><input type="hidden" name="form_build_id" value="form-gaPPqRe0COrx6zZ4OdzCxAHA3pbw7n2_oJsl2to_OAk" />
<input type="hidden" name="form_id" value="search_block_form" />
</form>    </div>

  </div>

  <div class="nav--bottom sticky-container">
    <div class="bg--dark-red sticky" data-margin="0" data-position="fixed">
      <div class="container">
        <a class="logo" href="/" title="Home" rel="home" class="logo">
          <img class="full" src="/sites/all/themes/yourobserver/images/logos/logo-white.svg" alt="Your Observer">
        </a>
        <nav class="site--main-nav" data-prepend=".right-nav" data-original=".nav--bottom .container">
          <ul class="links"><li class="first expanded item-wrapper-level-1 item-1135-wrap"><a href="/longboat-key" class="item-1135 item-level-1">Longboat Key</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1164-wrap"><a href="/lists/longboat-key/news/all" class="item-1164 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1168-wrap"><a href="/lists/longboat-key/neighbors/all" class="item-1168 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1165-wrap"><a href="/lists/longboat-key/opinion/all" class="item-1165 item-level-2"><span class="icon i-arrow-right-small"></span> Opinion</a></li>
<li class="leaf item-wrapper-level-2 item-1170-wrap"><a href="/lists/longboat-key/cops-corner/all" class="item-1170 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1263-wrap"><a href="/lists/longboat-key/business/all" class="item-1263 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="last leaf item-wrapper-level-2 item-1265-wrap"><a href="/lists/longboat-key/real-estate/all" class="item-1265 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1137-wrap"><a href="/east-county" class="item-1137 item-level-1">East County</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1173-wrap"><a href="/lists/east-county/news/all" class="item-1173 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1180-wrap"><a href="/lists/east-county/schools/all" class="item-1180 item-level-2"><span class="icon i-arrow-right-small"></span> Schools</a></li>
<li class="leaf item-wrapper-level-2 item-1267-wrap"><a href="/lists/east-county/neighbors/all" class="item-1267 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1179-wrap"><a href="/lists/east-county/sports/all" class="item-1179 item-level-2"><span class="icon i-arrow-right-small"></span> Sports</a></li>
<li class="leaf item-wrapper-level-2 item-1174-wrap"><a href="/lists/east-county/opinion/all" class="item-1174 item-level-2"><span class="icon i-arrow-right-small"></span> Opinion</a></li>
<li class="leaf item-wrapper-level-2 item-1177-wrap"><a href="/lists/east-county/cops-corner/all" class="item-1177 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1268-wrap"><a href="/lists/east-county/business/all" class="item-1268 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="last leaf item-wrapper-level-2 item-1266-wrap"><a href="/lists/east-county/real-estate/all" class="item-1266 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1136-wrap"><a href="/sarasota" class="item-1136 item-level-1">Sarasota</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1149-wrap"><a href="/lists/sarasota/news/all" class="item-1149 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1271-wrap"><a href="/lists/sarasota/schools/all" class="item-1271 item-level-2"><span class="icon i-arrow-right-small"></span> Schools</a></li>
<li class="leaf item-wrapper-level-2 item-1148-wrap"><a href="/lists/sarasota/neighbors/all" class="item-1148 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1272-wrap"><a href="/lists/sarasota/sports/all" class="item-1272 item-level-2"><span class="icon i-arrow-right-small"></span> Sports</a></li>
<li class="leaf item-wrapper-level-2 item-1150-wrap"><a href="/lists/sarasota/opinion/all" class="item-1150 item-level-2"><span class="icon i-arrow-right-small"></span> Opinion</a></li>
<li class="leaf item-wrapper-level-2 item-1145-wrap"><a href="/lists/sarasota/cops-corner/all" class="item-1145 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1273-wrap"><a href="/lists/sarasota/business/all" class="item-1273 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="last leaf item-wrapper-level-2 item-1274-wrap"><a href="/lists/sarasota/real-estate/all" class="item-1274 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1032-wrap"><a href="/siesta-key" class="item-1032 item-level-1">Siesta Key</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1160-wrap"><a href="/lists/siesta-key/news/all" class="item-1160 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1162-wrap"><a href="/lists/siesta-key/neighbors/all" class="item-1162 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="last leaf item-wrapper-level-2 item-1280-wrap"><a href="/lists/sarasota/real-estate/all" class="item-1280 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1284-wrap"><a href="/arts-and-entertainment" class="item-1284 item-level-1">Arts & Entertainment</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1855-wrap"><a href="/lists/arts-and-entertainment/eat-and-drink/all" class="item-1855 item-level-2"><span class="icon i-arrow-right-small"></span> Eat & Drink</a></li>
<li class="leaf item-wrapper-level-2 item-1476-wrap"><a href="/lists/arts-and-entertainment/music/all" class="item-1476 item-level-2"><span class="icon i-arrow-right-small"></span> Music</a></li>
<li class="leaf item-wrapper-level-2 item-1478-wrap"><a href="/lists/arts-and-entertainment/visual-art/all" class="item-1478 item-level-2"><span class="icon i-arrow-right-small"></span> Visual Art</a></li>
<li class="leaf item-wrapper-level-2 item-1479-wrap"><a href="/lists/arts-and-entertainment/performing-art/all" class="item-1479 item-level-2"><span class="icon i-arrow-right-small"></span> Performing Art</a></li>
<li class="leaf item-wrapper-level-2 item-1480-wrap"><a href="/lists/arts-and-entertainment/this-week/all" class="item-1480 item-level-2"><span class="icon i-arrow-right-small"></span> This Week</a></li>
<li class="leaf item-wrapper-level-2 item-1483-wrap"><a href="/lists/arts-and-entertainment/reviews/all" class="item-1483 item-level-2"><span class="icon i-arrow-right-small"></span> Reviews</a></li>
<li class="last leaf item-wrapper-level-2 item-1875-wrap"><a href="/arts-and-entertainment/calendar" class="item-1875 item-level-2"><span class="icon i-arrow-right-small"></span> A & E Calendar</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1141-wrap"><a href="/black-tie" class="item-1141 item-level-1">Black Tie</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1697-wrap"><a href="/photo-galleries/black-tie/all" class="item-1697 item-level-2"><span class="icon i-arrow-right-small"></span> Photos</a></li>
<li class="leaf item-wrapper-level-2 item-1489-wrap"><a href="/blacktieapp" class="item-1489 item-level-2"><span class="icon i-arrow-right-small"></span> Social Calendar</a></li>
<li class="leaf item-wrapper-level-2 item-1854-wrap"><a href="/lists/black-tie/black-tie-and-tales/all" class="item-1854 item-level-2"><span class="icon i-arrow-right-small"></span> Black Tie & Tales</a></li>
<li class="leaf item-wrapper-level-2 item-1936-wrap"><a href="/lists/black-tie/style/all" class="item-1936 item-level-2"><span class="icon i-arrow-right-small"></span> Style</a></li>
<li class="last leaf item-wrapper-level-2 item-1918-wrap"><a href="/lists/black-tie/familiar-faces/all" class="item-1918 item-level-2"><span class="icon i-arrow-right-small"></span> Familiar Faces</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1255-wrap"><a href="/photo-galleries/all/all" class="item-1255 item-level-1">Photo Galleries</a><ul class="sub-menu sub-level-2"><li class="first last leaf item-wrapper-level-2 item-1903-wrap"><a href="/photos" class="item-1903 item-level-2"><span class="icon i-arrow-right-small"></span> Search Photos</a></li>
</ul></li>
<li class="last expanded item-wrapper-level-1 item-2099-wrap"><a href="https://www.yourobserver.com" class="item-2099 item-level-1">More</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-2106-wrap"><a href="https://www.yourobserver.com/newsies" class="item-2106 item-level-2"><span class="icon i-arrow-right-small"></span> Be a Newsie</a></li>
<li class="leaf item-wrapper-level-2 item-2101-wrap"><a href="https://www.yourobserver.com/calendar" class="item-2101 item-level-2"><span class="icon i-arrow-right-small"></span> Calendar</a></li>
<li class="leaf item-wrapper-level-2 item-2100-wrap"><a href="https://www.yourobserver.com/contests" class="item-2100 item-level-2"><span class="icon i-arrow-right-small"></span> Contests</a></li>
<li class="collapsed item-wrapper-level-2 item-2082-wrap"><a href="/lists/all/celebrations/all" class="item-2082 item-level-2"><span class="icon i-arrow-right-small"></span> Celebrations</a></li>
<li class="leaf item-wrapper-level-2 item-2084-wrap"><a href="/celebrations" class="item-2084 item-level-2"><span class="icon i-arrow-right-small"></span> Submit a Celebration</a></li>
<li class="leaf item-wrapper-level-2 item-1929-wrap"><a href="/lists/all/tributes/all" class="item-1929 item-level-2"><span class="icon i-arrow-right-small"></span> Tributes / Obits</a></li>
<li class="leaf item-wrapper-level-2 item-1930-wrap"><a href="/tributes" class="item-1930 item-level-2"><span class="icon i-arrow-right-small"></span> Submit a Tribute / Obit</a></li>
<li class="last leaf item-wrapper-level-2 item-1698-wrap"><a href="/lists/east-county/lwr-life/all" class="item-1698 item-level-2"><span class="icon i-arrow-right-small"></span> LWR Life Magazine</a></li>
</ul></li>
</ul>        </nav>
      </div>

      <div class="header-search">
        <span class="icon close-icon"></span>
        <form action="/photo-gallery/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend" method="post" id="search-block-form" accept-charset="UTF-8">
  <h2 class="element-invisible">Search form</h2>

<div>
  <label class="element-invisible" for="edit-search-block-form--2">Search</label>
 <input title="Enter the terms you wish to search for." placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="30" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" /></div><input type="hidden" name="form_build_id" value="form-gaPPqRe0COrx6zZ4OdzCxAHA3pbw7n2_oJsl2to_OAk" />
<input type="hidden" name="form_id" value="search_block_form" />
</form>      </div>
    </div>
  </div>

</div>
  </header>

  <div id="header_ad" class="advert-bar advert-bar--header bg--mild-grey">
    <div class="advert-wrapper">
      <div id="dfp-ad-header-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-header" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-header");
      });
  </script>
</div>
</div>    </div>
  </div>

<div class="page-wrapper">

      
      
      
      
        
    <div class="module--slider synced header--full has--image">

    <span class="gen-loader gallery-loading">Loading Gallery...</span>

    <div class="sync-1 rsDefault large">
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360880_standard.jpeg?itok=dSzqpGhu" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360880_standard.jpeg" title="Art and Soul Dance Company will be performing in front of thousands during the Daytona 500 weekend." alt="Art and Soul Dance Company will be performing in front of thousands during the Daytona 500 weekend.">Art and Soul Dance Company will be performing in front of thousands during the Daytona 500 weekend.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360880_standard.jpeg?itok=iAItYoQf" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <h1 class="title zeta">Lakewood Ranch dance company super charged to perform during Daytona 500 weekend</h1>
                          <p>Friday, Nov. 5, 2021 | </p><h2> Art and Soul Dance Company will be performing in front of thousands during the Daytona 500 weekend.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360881_standard.jpeg?itok=Yf_56Dii" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360881_standard.jpeg" title="Claire Gonzales does a routine with Meadow Edoff in the back. Gonzales says she will channel her nervous energy in a positive way." alt="Claire Gonzales does a routine with Meadow Edoff in the back. Gonzales says she will channel her nervous energy in a positive way.">Claire Gonzales does a routine with Meadow Edoff in the back. Gonzales says she will channel her nervous energy in a positive way.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360881_standard.jpeg?itok=Xu49TRq4" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Claire Gonzales does a routine with Meadow Edoff in the back. Gonzales says she will channel her nervous energy in a positive way.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360882_standard.jpeg?itok=AYc_r3bR" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360882_standard.jpeg" title="Kayla Downes says her fellow dancers must have self confidence when they perform on the big stage." alt="Kayla Downes says her fellow dancers must have self confidence when they perform on the big stage.">Kayla Downes says her fellow dancers must have self confidence when they perform on the big stage.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360882_standard.jpeg?itok=v-oeK0mO" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Kayla Downes says her fellow dancers must have self confidence when they perform on the big stage.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360883_standard.jpeg?itok=PH7NWS8K" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360883_standard.jpeg" title="Veronika Voronenko and Khaliah Padilla will need lots of sleep to be ready for their Daytona 500 performance." alt="Veronika Voronenko and Khaliah Padilla will need lots of sleep to be ready for their Daytona 500 performance.">Veronika Voronenko and Khaliah Padilla will need lots of sleep to be ready for their Daytona 500 performance.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360883_standard.jpeg?itok=P-3xyXYc" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Veronika Voronenko and Khaliah Padilla will need lots of sleep to be ready for their Daytona 500 performance.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360884_standard.jpeg?itok=uTN5GWXC" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360884_standard.jpeg" title="Hayden Schmidt works on a routine with Anthony Longo in the back." alt="Hayden Schmidt works on a routine with Anthony Longo in the back.">Hayden Schmidt works on a routine with Anthony Longo in the back.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360884_standard.jpeg?itok=72nrieLt" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Hayden Schmidt works on a routine with Anthony Longo in the back.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360885_standard.jpeg?itok=09d5of5R" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360885_standard.jpeg" title="Claire Gonzales, Kayla Downes and Anthony Longo work during a rehearsal at Art and Soul Dance Company." alt="Claire Gonzales, Kayla Downes and Anthony Longo work during a rehearsal at Art and Soul Dance Company.">Claire Gonzales, Kayla Downes and Anthony Longo work during a rehearsal at Art and Soul Dance Company.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360885_standard.jpeg?itok=IzEY3M0A" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Claire Gonzales, Kayla Downes and Anthony Longo work during a rehearsal at Art and Soul Dance Company.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360886_standard.jpeg?itok=LKb0zBXk" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360886_standard.jpeg" title="Kayla Downes says the hard work in practice makes the routines seem easy on stage." alt="Kayla Downes says the hard work in practice makes the routines seem easy on stage.">Kayla Downes says the hard work in practice makes the routines seem easy on stage.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360886_standard.jpeg?itok=xxUz-0kT" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Kayla Downes says the hard work in practice makes the routines seem easy on stage.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360887_standard.jpeg?itok=sd3j4u1p" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360887_standard.jpeg" title="Mya Copeland works through a routine." alt="Mya Copeland works through a routine.">Mya Copeland works through a routine.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360887_standard.jpeg?itok=MrHo7t5N" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Mya Copeland works through a routine.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360888_standard.jpeg?itok=f26EZUGW" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360888_standard.jpeg" title="Claire Gonzales admits she doesn&#39;t know a lot about the Daytona 500, but she knows the crowd will be large." alt="Claire Gonzales admits she doesn&#39;t know a lot about the Daytona 500, but she knows the crowd will be large.">Claire Gonzales admits she doesn&#39;t know a lot about the Daytona 500, but she knows the crowd will be large.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360888_standard.jpeg?itok=MGCjIalj" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Claire Gonzales admits she doesn&#39;t know a lot about the Daytona 500, but she knows the crowd will be large.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360889_standard.jpeg?itok=1wsAQHVI" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360889_standard.jpeg" title="Mya Richard-Bennet concentrates on her movements during a workout." alt="Mya Richard-Bennet concentrates on her movements during a workout.">Mya Richard-Bennet concentrates on her movements during a workout.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360889_standard.jpeg?itok=_ULFFiUB" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Mya Richard-Bennet concentrates on her movements during a workout.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360891_standard.jpeg?itok=z9uxfNYz" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360891_standard.jpeg" title="Claire Gonzales gives her teammate encouragement during a workout." alt="Claire Gonzales gives her teammate encouragement during a workout.">Claire Gonzales gives her teammate encouragement during a workout.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360891_standard.jpeg?itok=UxCb1Jej" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Claire Gonzales gives her teammate encouragement during a workout.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360892_standard.jpeg?itok=7AxsopO-" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360892_standard.jpeg" title="Mya Richard-Bennet shows off a little personality during a dance." alt="Mya Richard-Bennet shows off a little personality during a dance.">Mya Richard-Bennet shows off a little personality during a dance.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360892_standard.jpeg?itok=TN-KUcbq" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Mya Richard-Bennet shows off a little personality during a dance.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360893_standard.jpeg?itok=Ba6nwOMP" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360893_standard.jpeg" title="Isabella Abreu will be among a team of 30 dancers performing during the Daytona 500 weekend." alt="Isabella Abreu will be among a team of 30 dancers performing during the Daytona 500 weekend.">Isabella Abreu will be among a team of 30 dancers performing during the Daytona 500 weekend.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360893_standard.jpeg?itok=OMmosBik" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Isabella Abreu will be among a team of 30 dancers performing during the Daytona 500 weekend.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360894_standard.jpeg?itok=4uobxCWc" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360894_standard.jpeg" title="Claire Gonzales and her Art and Soul teammates will perform at the Daytona International Motor Speedway." alt="Claire Gonzales and her Art and Soul teammates will perform at the Daytona International Motor Speedway.">Claire Gonzales and her Art and Soul teammates will perform at the Daytona International Motor Speedway.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360894_standard.jpeg?itok=wA6gTlk0" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> Claire Gonzales and her Art and Soul teammates will perform at the Daytona International Motor Speedway.</h2>

          </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/360895_standard.jpeg?itok=mGzNMJaE" data-rsBigImg="https://www.yourobserver.com/sites/default/files/360895_standard.jpeg" title="NASCAR already has shipped a banner to Art and Soul Dance Company." alt="NASCAR already has shipped a banner to Art and Soul Dance Company.">NASCAR already has shipped a banner to Art and Soul Dance Company.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/360895_standard.jpeg?itok=NC00AhW8" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 5, 2021 | </p><h2> NASCAR already has shipped a banner to Art and Soul Dance Company.</h2>

          </div>
        </div>
          </div>

    <div class="module--slider-nav">
      <span id="prev-image" class="icon arrow-left-icon prev" data-direction="prev"></span>
      <span id="next-image" class="icon arrow-right-icon next" data-direction="next"></span>
    </div>

    <span class="icon expand-icon zeta"></span>

    

    <div class="ad-container">
      <div id="sign--up-wrapper" class="side--bar-signup"></div>
      <div id="dfp-ad-photo_gallery-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-photo_gallery" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-photo_gallery");
      });
  </script>
</div>
</div>    </div>

  </div> <!-- sync-slider -->



<main class="section overflow-sticky">
  <div class="container large">
    <div class="col-2-3 page-content">
      <article about="/photo-gallery/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend" typeof="sioc:Item foaf:Document" class="photo-gallery">

      
        <div class="overflow-sticky">
                              <div class="sticky-container">
           <div class="article-social-bar sticky bg--lightest-grey" data-margin="nav" data-position="absolute">
              <span class="label text--red">Share</span>
              <ul class="social-icons">
                              <li>
                  <a href="#" class="link social-share" onclick="customFBShare(); return false;"><span class="icon facebook-icon"></span></a>
                                  </li>
                                            <li>
                  <a href="# " data-social="{&quot;type&quot;:&quot;twitter&quot;,&quot;url&quot;:&quot;https:\/\/www.yourobserver.com\/photo-gallery\/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend&quot;,&quot;text&quot;:&quot;Lakewood Ranch dance company super charged to perform during Daytona 500 weekend&quot;}" class="link social-share"><span class="icon twitter-icon"></span></a>                </li>
                              <li>
                  <a href="/cdn-cgi/l/email-protection#be8198cdcbdcd4dbddca83f1dccddbccc8dbcc9b8c8ef3dbdad7df9b8c8ef9ccd1cbce9b8c8e939b8c8ef2dfd5dbc9d1d1da9eecdfd0ddd69edadfd0dddb9eddd1d3cedfd0c79ecdcbcedbcc9eddd6dfccd9dbda9ecad19ecedbccd8d1ccd39edacbccd7d0d99efadfc7cad1d0df9e8b8e8e9ec9dbdbd5dbd0da98dcd1dac783d6cacacecd849191c9c9c990c7d1cbccd1dccddbccc8dbcc90ddd1d391ced6d1cad193d9dfd2d2dbccc791d2dfd5dbc9d1d1da93ccdfd0ddd693dadfd0dddb93ddd1d3cedfd0c793cdcbcedbcc93ddd6dfccd9dbda93cad193cedbccd8d1ccd393dacbccd7d0d993dadfc7cad1d0df938b8e8e93c9dbdbd5dbd0da" target="_top" class="" title="Email This Page">
                    <span class="icon mail-icon"></span>
                  </a>
                </li>
              </ul>
              <a id="ps_disqus" href="#disqus_thread" class="comments right scrollto" data-scroll-target="disqus"></a>
           </div>
          </div>

                      <h6 class="dek left-margin">




  Art and Soul Dance Company of Lakewood Ranch receives an invitation to perform during Daytona 500 weekend.


</h6>
          
                                    




  <div class="author left-margin">
	by: 
	<a href="/articles/author/jay-heater" title="See All Articles by Jay Heater" class="text--red">
		




  Jay Heater


	</a>
	<span>




  Managing Editor


</span>
</div>



                      


          <div id="content--wrapper" class="content--wrapper">
            <div class="p402_premium">
              




  <p>Nine-year-old Jace Brush might not understand much about NASCAR, but he certainly does know numbers.</p>

<p>Try 101,500, for instance, the seating capacity at Daytona International Speedway.</p>

<p>Bruce is a member of Lakewood Ranch&#39;s Art and Soul Dance Company, which on Oct 27 was invited to perform during the Daytona 500 weekend at Daytona International Speedway.</p>

<p>Although Art and Soul will perform on Feb. 19, the day before the Daytona 500, there are two major races that day, including the&nbsp;NASCAR Xfinity Series season-opener, a 300-lap race.</p>


<aside class="content--sidebar half-size inline-left"><h6>Headed for Daytona 500 weekend</h6><p><p>What: Art and Soul Dance Company of Lakewood Ranch is invited to perform at the Daytona 500 weekend</p>

<p>Where: Daytona International Speedway</p>

<p>When: Time TBA, Feb. 19&nbsp;</p>

<p>Featured that day: NASCAR Xfinity Beef. It&#39;s What&#39;s for Dinner. 300</p>

<p>Members in Art and Soul Dance Company: 30</p>

<p>More information: ArtAndSoulDance.com</p>
</p></aside>


<p>As Art and Soul Executive Director&nbsp;Danielle Downes said, &quot;You could have 10s of thousands of people there.&quot;</p>

<p>Would that make Bruce nervous?</p>

<p>&quot;Oh God, yeah!&quot; Bruce said. &quot;I will be nervous.&quot;</p>

<p>It&#39;s an excited, fun, nervous feeling that swept through the team after it&nbsp;learned of the honor.</p>

<p>&quot;These girls and boys haven&#39;t performed on a stage that big,&quot; Downes said. &quot;They haven&#39;t performed in something of this magnitude. When you talk about this race, you are talking about the Super Bowl of racing.&quot;</p>

<p>Even so, Downes and Art and Soul Dance Company owner&nbsp;Alana Turner are certain their performers will rise to the challenge, as they have time after time in winning the many trophies on display in their studio.</p>

<p>&quot;Part of our instruction is how to harness and channel that kind of energy,&quot; Turner said. &quot;How do you manage that?&quot;</p>

<p>Downes told the performers and many of them understood the scope of the invitation. But with performers from the age of 4 through 16, not all of them did.</p>

<p>&quot;The littlest guys ... not so much,&quot; Downes said.</p>

<p>Brush said he once performed in front of about 100 people, but he wasn&#39;t nervous because the lights were off in the auditorium and he couldn&#39;t see into the crowd.</p>

<p>Lakewood Ranch 14-year-old Eve Hare said her parents &quot;freaked out&quot; when they heard Art and Soul was headed toward Daytona.</p>

<p>&quot;Everyone in my family is a big racing fan,&quot; she said. &quot;This is a huge deal.&quot;</p>

<p>Claire Gonzales, a 15-year-old Lakewood Ranch resident, said&nbsp;she doesn&#39;t know much about the Daytona 500 other than &quot;I&#39;ve certainly heard of it.&quot;</p>

<p>A fourth-year dancer, she does know the team will be watched by its biggest crowd ever.</p>

<p>&quot;Maybe I will be a little nervous,&quot; she said. &quot;But I will use it to have more energy.&quot;</p>

<p>Lakewood Ranch&#39;s Kayla Downes, 15, said the thought of performing in front of thousands of people is &quot;crazy,&quot; but she said her training will make her confident.</p>

<p>&quot;Stress-wise, I have to know I&#39;m good,&quot; she said.</p>

<p>Kayla Downes said the team will work hard to make its routines appear easy, even if they aren&#39;t.</p>

<p>&quot;All those people can&#39;t know it&#39;s hard,&quot; she said.</p>

<p>The 30-member team (27 girls, 3 boys) will perform for approximately 20 minutes. Most of the routine will be made up of their usual competition performance, but a 3- to 4-minute special dance will be added.</p>

<p>&quot;(The Daytona 500 organizers) deserve&nbsp;something specifically designed for them,&quot; Turner said. &quot;We will find an appropriate song.&nbsp;Disney&#39;s Cars?&quot;</p>

<p>Art and Soul Dance Company was fortunate because the Daytona 500 weekend occurs just before the start of its competitive season in March. The special event will be used to kickoff the season and Danielle Downs said extra practice sessions will be involved.</p>

<p>&quot;For us, this is a chance to show the level of technique these girls and boys have acquired,&quot; she said. &quot;We need to be flawless.&quot;</p>

<p>Turner said it&#39;s another opportunity for the performers to see how their hard work pays off.</p>

<p>For Brush, it would be a chance for him to learn more about the Daytona 500. Of course, he did pick up some knowledge about the race once he found out he was going.</p>

<p>&quot;My dad told me they only go left,&quot; Brush said of his dad&#39;s explanation of how the drivers race on an oval.</p>


            </div>
            <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
              try { _402_Show(); } catch(e) {}
            </script>
                          <div class="PicoSignal pico-article-cta-YO">
                <a href="#" class="PicoPopup_qke3p5m9"><img class="pico-image" src="https://cdn.digitalobservermedia.com/yourobserver.com/pico/newsie-cta.jpg" alt=""></a>
<p class="pico-cta-text">Join the Neighborhood! Our 100% local content helps strengthen our communities by delivering news and information that is relevant to our readers. Support independent local journalism by joining the Observer's new membership program &mdash; The Newsies &mdash; a group of like-minded community citizens, like you. <a href="#" class="PicoPopup_qke3p5m9">Be a Newsie</a>.</p>              </div>
                      </div>
        </div>

        
        

      </article>

              <div class="pagination-wrapper">

                      <a href="/article/music-on-main-cancelled-in-lakewood-ranch" class="col-1-2 bg--lightest-grey pagination-item prev">
              <div class="label left-icon">
                <span class="icon line-arrow-left-long-icon"></span>
                <span class="text">Prev Article</span>
              </div>
              <h6 class="title">Music on Main cancelled in Lakewood Ranch</h6>
            </a>
          
          
        </div>
      
    </div> <!-- col-2-3 -->

    <div class="col-1-3 sidebar">
      
              <div id="ad_wrapper_t" class="advert-sidebar" data-margin="80" data-position="absolute" data-append="">
          <div id="ad_wrapper_top">
            <div id="dfp-ad-stacked_top-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-stacked_top" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-stacked_top");
      });
  </script>
</div>
</div>                              <div id="dfp-ad-half_page-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-half_page" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-half_page");
      });
  </script>
</div>
</div>                        </div>
        </div>

        <div id="email-sign-up" class="PicoSignal side--bar-signup">
          <div class="module signup">
            <h6 class="section-title text--red">sign up to receive our news in your inbox!</h6>
                          <form class="PicoSignupForm mailchimp-signup-subscribe-form">
              <div class="form-required">
                <label class="required">Email Address</label>
                <input type="email" name="email" value="" size="30" maxlength="128" required="">
              </div>
              <input type="submit" value="Submit">
            </form>                      </div>
        </div>

        <div class="section pad">
            <ul id="most_popular" data-margin="80" data-position="absolute" data-append=""></ul>
        </div>
      
      <div class="section pad sticky-container">
        <div id="ad_wrapper_b" class="advert-sidebar sticky" data-margin="80" data-position="absolute" data-append="">
          <div id="ad_wrapper_bottom">
            <div id="dfp-ad-stacked_bottom-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-stacked_bottom" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-stacked_bottom");
      });
  </script>
</div>
</div>                        	<div id="dfp-ad-stacked_bottom_2-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-stacked_bottom_2" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-stacked_bottom_2");
      });
  </script>
</div>
</div>          	          </div>
        </div>
      </div>

    </div>

  </div><!-- container -->

  

      <section class="section pad bg--lighter-grey">
      <div class="container">

        <header class="section-title">
          <h2 class="title delta bg--red">Related Stories</h2>
        </header>

        <div class="col-2-3">
          <div id="related_stories" class="section teasers"></div>
        </div>

                  <div class="col-2-3">
            <div id="rc-widget-e1c45c" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="115384"></div>
            <script type="text/javascript" src="//assets.revcontent.com/master/delivery.js" defer="defer"></script>
          </div>
        
        <div class="col-2-3 disqus--wrapper" data-scroll-anchor="disqus">
          <div id="disqus_thread"><noscript><p><a href="http://yourobserver.disqus.com/?url=https%3A%2F%2Fwww.yourobserver.com%2Fphoto-gallery%2Flakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend">View the discussion thread.</a></p></noscript></div>        </div>

      </div>
    </section>
  
  <div id="mobile_ad_container_top" class="ad-hide">
    <div id="mobile_ad_placement_top" class="advert-sidebar bg--mild-grey ad-hide" data-margin="80" data-position="absolute" data-append="">

    </div>
  </div>

  <div id="mobile_ad_container_bottom" class="ad-hide">
    <div id="mobile_ad_placement_bottom" class="advert-sidebar bg--mild-grey ad-hide" data-margin="80" data-position="absolute" data-append="">

    </div>
  </div>

</main>
      
      

      
    
  
</div><!-- /page-->

<div id="sticky-footer">
  <div id="dfp-ad-sticky_footer-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-sticky_footer" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-sticky_footer");
      });
  </script>
</div>
</div></div>

  

<footer class="site--footer">

      <div id="footer_ad" class="advert-bar advert-bar--footer bg--mild-grey">
      <div class="advert-wrapper">
        <div id="dfp-ad-footer-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-footer" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-footer");
      });
  </script>
</div>
</div>      </div>
    </div>
  
  <div class="footer-nav">
    <div class="section bg--lightest-grey">
      <ul class="links"><li class="first leaf item-wrapper-level-1 item-1202-wrap"><a href="/about-us" class="item-1202 item-level-1">About</a></li>
<li class="leaf item-wrapper-level-1 item-1204-wrap"><a href="/contact-us" class="item-1204 item-level-1">Contact Us</a></li>
<li class="leaf item-wrapper-level-1 item-1205-wrap"><a href="http://classifieds.yourobserver.com/" class="item-1205 item-level-1">Classifieds</a></li>
<li class="leaf item-wrapper-level-1 item-1314-wrap"><a href="/advertise" title="Advertise" class="item-1314 item-level-1">Advertise</a></li>
<li class="leaf item-wrapper-level-1 item-1207-wrap"><a href="/rack-locations" class="item-1207 item-level-1">Rack Locations</a></li>
<li class="leaf item-wrapper-level-1 item-1208-wrap"><a href="/subscribe" class="item-1208 item-level-1">Subscribe</a></li>
<li class="leaf item-wrapper-level-1 item-1210-wrap"><a href="/jobs" class="item-1210 item-level-1">Jobs</a></li>
<li class="leaf item-wrapper-level-1 item-1319-wrap"><a href="/sponsorships" class="item-1319 item-level-1">Sponsorships</a></li>
<li class="last leaf item-wrapper-level-1 item-1242-wrap"><a href="/privacy-policy" class="item-1242 item-level-1">Privacy Policy</a></li>
</ul>    </div>
  </div>

  <div class="section contact-social-signup bg--lighter-grey">
    <div class="col-2-3 module">

      <div class="col-1-2 module contact">
        <h4 class="section-title text--red">Contact Us</h4>
        <img class="logo" src="/sites/all/themes/yourobserver/images/logos/logo-gray.svg" alt="Your Observer Logo" />
        <div class="grid">
          <div class="col-1-2">
            1970 Main Street <br>
                          Third Floor<br>
                        Sarasota, FL&nbsp;34236          </div>
          <div class="col-1-2">
            <b>Phone:</b> <a href="tel:941-366-3468">941-366-3468</a><br>
            <b>Fax:</b>   <a href="tel:941-362-4808">941-362-4808</a><br>
            <b>Email:</b> <a href="/cdn-cgi/l/email-protection#9eb8f0fcedeea5">&nbsp;</a>
          </div>
        </div>
      </div>

      <div class="col-1-2 module socialize">
        <h4 class="section-title text--red">Socialize With Us</h4>
        <div class="grid">

        	          	<a href="https://www.facebook.com/ObserverGroup" class="icon facebook-icon col-1-6" target="_blank"></a>
          
                    	<a href="https://twitter.com/ObserverGroup" class="icon twitter-icon col-1-6" target="_blank"></a>
          
                      <a href="https://www.instagram.com/observergroup/" class="icon instagram-icon col-1-6" target="_blank"></a>
          
          
                    	<a href="https://www.youtube.com/user/YourObserverVideo" class="icon youtube-icon col-1-6" target="_blank"></a>
          
                    	<a href="https://www.linkedin.com/company/the-observer-group?trk=company_logo" class="icon linkedin-icon col-1-6" target="_blank"></a>
          
          
        </div>
      </div>
    </div>

    <div class="col-1-3 module signup">
      <h4 class="section-title text--red">sign up to receive our news in your inbox!</h4>
              <form class="PicoSignupForm mailchimp-signup-subscribe-form">
      <div class="form-required">
        <label class="required">Email Address</label>
        <input type="email" name="email" value="" size="30" maxlength="128" required="">
      </div>
      <input type="submit" value="Submit">
    </form>                </div>
  </div>

  <div class="section bg--dark-grey">
    <div class="col-4-7 module sister-sites">
      <h4 class="section-title">Our Sister Sites</h4>

                    
                      <div class="grid">
                      
          <a href="http://www.businessobserverfl.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/business.png?itok=ulxToCJ3" alt="" /></a>
                        
          
          <a href="http://www.palmcoastobserver.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/palmcoast.png?itok=9DShShL7" alt="" /></a>
                                  </div>
                        
                      <div class="grid">
                      
          <a href="http://www.orangeobserver.com" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/orange.png?itok=ky46z5ix" alt="" /></a>
                        
          
          <a href="http://www.ormondbeachobserver.com" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/ormond.png?itok=d1OhVE0m" alt="" /></a>
                                  </div>
                        
                      <div class="grid">
                      
          <a href="https://www.portorangeobserver.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/port.png?itok=wZRn9KmU" alt="" /></a>
                        
          
          <a href="https://www.jaxdailyrecord.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/jax.png?itok=vhKvdwtA" alt="" /></a>
                                  </div>
                      
      
    </div>

    <div class="col-3-7 right module other-pubs">
      <h4 class="section-title">Other Publications</h4>
      <div class="inner">
                	<img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/other_publications_200x140/public/media/other-pubs_0_0.png?itok=7SbC7L-C" alt="" />                <p>
        	        		Browse a digital collection of our other publications, magazines and special sections such as Season Magazine, Health Matters, Holiday Gift Guide and more .        	        </p>
        <a href="/e-editions" class="button">VIEW ALL<span class="cta-right"></span></a>      </div>
    </div>
  </div>

  <div class="copy-bar">
    <span class="text">Copyright &copy;&nbsp;2021&nbsp;Observer Media Group, Inc., All Rights Reserved</span>
    <a class="right" href="http://www.atlargeinc.com" target="_blank"><img src="/sites/all/modules/features/tog_site_wide/theme/atlarge-logo.svg" alt="Site created by atLarge inc."></a>
  </div>

</footer>

<!-- The Modal -->
<div id="myModal" class="modal">

  <!-- Modal content -->
  <div class="modal-content">
    <span class="close">&times;</span>
    <div class="logo-wrapper">
      <img class="logo" src="/sites/all/themes/yourobserver/images/logos/logo-gray.svg" alt="Your Observer Logo" />
    </div>
    <h5 id="myModalHeader" class="section-title text--red">We've noticed you like reading articles on our site.</h5>
    <div id="#limit" class="related-modal-wrapper" style="position: relative; overflow: hidden;">
      <div id="related_stories_modal"></div>
    </div>
    <div class="modal-signup">
      <div id="secondary_header" class="module signup">
        <h6 class="section-title text--red">sign up to receive our news in your inbox!</h6>
              </div>
    </div>
  </div>

</div>
  
  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="/sites/all/modules/custom/tog_most_popular/js/tog_most_popular_track.js?r23to1"></script>
<script src="/sites/all/themes/yourobserver/scripts/dist/app.js?r23to1"></script>
<script src="/sites/all/themes/yourobserver/scripts/ads.js?r23to1"></script>
<script src="/sites/all/themes/yourobserver/scripts/block_buster.js?r23to1"></script>
<script src="/sites/all/themes/yourobserver/scripts/pico/omgPico.js?r23to1"></script>
<script src="/sites/all/modules/custom/tog_most_popular/js/tog_most_popular.js?r23to1"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_share.js?r23to1"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_related.js?r23to1"></script>
<script src="/sites/all/modules/features/tog_people/js/tog_people_stories.js?r23to1"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_disqus.js?r23to1"></script>
      <script type="application/ld+json">
      {"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.yourobserver.com\/photo-gallery\/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend"},"headline":"Lakewood Ranch dance company super charged to perform during Daytona 500 weekend","image":{"@type":"ImageObject","url":"https:\/\/www.yourobserver.com\/sites\/default\/files\/styles\/sliders_and_planned_story_image_870x580\/public\/360880_standard.jpeg?itok=dSzqpGhu","height":580,"width":870},"datePublished":"2021-11-05T11:10:00-04:00","dateModified":"2021-11-05T11:28:18-04:00","author":{"@type":"Person","name":"Jay Heater"},"publisher":{"@type":"Organization","name":"Your Observer","logo":{"@type":"ImageObject","url":"https:\/\/www.yourobserver.com\/sites\/all\/themes\/yourobserver\/images\/logos\/logo-bright.png","width":323,"height":33}},"description":"Art and Soul Dance Company of Lakewood Ranch receives an invitation to perform during Daytona 500 weekend."}    </script>
    <div id="adsense" style="position:absolute; top:10px; left:-999999px;">Advertisement</div>
  <div id="conversion_overlay" style="position: fixed; display: none; width: 100%; height: 100%;top: 0; left: 0;right: 0; bottom: 0; background-color: rgba(0,0,0,.9); z-index: 9999;"></div>
  <!-- PICO -->
      <script>
      var pageInfo = {"article":true,"post_type":"Photo Gallery","taxonomies":{"Publication":["East County"],"Section":["News"],"Byline":["Jay Heater"]},"post_id":"YO-D7-814201","url":"https:\/\/www.yourobserver.com\/photo-gallery\/lakewood-ranch-dance-company-super-charged-to-perform-during-daytona-500-weekend"};
      window.pico('visit', pageInfo);
    </script>
    </body>
</html>
