<!DOCTYPE html>

  <!--[if lt IE 7 ]><html class="no-js ie ie6 oldie" lang="en"> <![endif]-->
  <!--[if IE 7 ]><html class="no-js ie ie7 oldie" lang="en"> <![endif]-->
  <!--[if IE 8 ]><html class="no-js ie ie8 oldie" lang="en"> <![endif]-->
  <!--[if IE 9 ]><html class="no-js ie ie9" lang="en"> <![endif]-->
  <!--[if (gte IE 9)|!(IE)]><!--><html lang="en" class="loaded"> <!--<![endif]-->
  <head>
    <title>AJC’s 2017 Civic Achievement Award Dinner honors Jennifer Rominiecki | Black Tie | Your Observer</title>

    <!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="https://www.yourobserver.com/sites/all/themes/yourobserver/favicon.ico" />
<script>dataLayer = [{"entityType":"node","entityBundle":"planned_story","entityId":"209669","entityLabel":"AJC\u2019s 2017 Civic Achievement Award Dinner honors Jennifer Rominiecki","entityLanguage":"und","entityTnid":"0","entityVid":"209771","entityName":"admin","entityUid":"1","entityCreated":"1510958447","entityStatus":"1","entityTaxonomy":{"planned_story_type":{"2":"Photo Gallery"},"publication":{"259":"Black Tie"},"planned_story_section":{"29":"Black Tie"}},"drupalLanguage":"en","userUid":0,"entityAuthor":"Niki Kottmann"}];</script>
<link rel="amphtml" href="https://www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki?amp" />
<meta name="google-site-verification" content="NhzK4FRO_M2NOv6dXIvbzW8cP7sCfyrssSGx8x1jWkU"><meta property="fb:pages" content="288643121405"><meta name="google-site-verification" content="NhzK4FRO_M2NOv6dXIvbzW8cP7sCfyrssSGx8x1jWkU"><meta name="description" content="The annual award dinner recognized the president and CEO of Marie Selby Botanical Gardens on Nov. 16 at Michael’s On East." />
<meta name="keywords" content="AJC, 2017 Civic Achievement Award Dinner, Jennifer Rominiecki, fundraiser, Michael’s On East, American Jewish Committee, Sarasota," />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki" />
<link rel="shortlink" href="https://www.yourobserver.com/node/209669" />
<meta property="og:site_name" content="Your Observer" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki" />
<meta property="og:title" content="AJC’s 2017 Civic Achievement Award Dinner honors Jennifer Rominiecki | Black Tie | Your Observer" />
<meta property="og:description" content="The annual award dinner recognized the president and CEO of Marie Selby Botanical Gardens on Nov. 16 at Michael’s On East." />
<meta property="og:updated_time" content="2017-11-17T21:30:01-05:00" />
<meta property="article:published_time" content="2017-11-17T17:40:47-05:00" />
<meta property="article:modified_time" content="2017-11-17T21:30:01-05:00" />

    <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
    <meta name="google-site-verification" content="W5qEe1V8ciPqgo7dPyNIXQ-wHbIW1dBCGQ-dzCLvNgQ" />

    <meta http-equiv="cleartype" content="on">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

          <meta property="og:image" content="https://www.yourobserver.com/sites/default/files/143035_standard.jpeg" />
    
          <link rel="alternate" type="application/rss+xml" title="RSS Feed | Your Observer" href="https://www.yourobserver.com/article/rss/black-tie/black-tie" />    
    <link rel="shortcut icon" href="https://www.yourobserver.com/sites/all/themes/yourobserver/favicon.ico?v=1.3">
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-152x152.png">
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-144x144.png">
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-120x120.png">
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-114x114.png">
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-72x72.png">
<link rel="apple-touch-icon-precomposed" href="https://www.yourobserver.com/sites/all/themes/yourobserver/images/touch-icons/touch-icon-57x57.png">
    <link rel="stylesheet" href="/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" />
<link rel="stylesheet" href="/sites/default/files/css/css_WoEEOylVBzEPvC9L6NbVNwmTw3Mj5ral3_o92xdcgKw.css" />
<link rel="stylesheet" href="/sites/default/files/css/css_5ELIb8NALLa3BH014SSuzp3Uvje_6hJS9HRLMB4K2jQ.css" />
<link rel="stylesheet" href="/sites/default/files/css/css_47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU.css" />

    <!--[if lte IE 8]>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/respond.js"></script>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/selectivizr.js"></script>
    <![endif]-->
    <!--[if lt IE 9]>
    <script src="https://www.yourobserver.com/sites/all/themes/yourobserver/scripts/dist/html5shiv.js"></script>
    <![endif]-->

    <script src="https://www.yourobserver.com/sites/default/files/js/js_T4WB8eTkFP2vr9MeN1vxTJd6ydT9zxE09kBX0G3Uaos.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.9/jquery.min.js'>\x3C/script>")</script>
<script src="https://www.yourobserver.com/sites/default/files/js/js_PdiuypZMI8o81AYEdTHwjRslVPEF69JFzr7Y9sMWt4s.js"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="https://www.yourobserver.com/sites/default/files/js/js_8pEoWnUr8ijKw1SExt7kT6gNr85MGL-IZJyQGXvJRP0.js"></script>
<script>var mapping = googletag.sizeMapping()
  .addSize([1018, 0], [970, 66])
  .addSize([0, 0], [320, 50])
  .build();
googletag.slots["footer"] = googletag.defineSlot("/30582678/OMG/yourobserver/black-tie/black-tie", [[970, 66], [320, 50]], "dfp-ad-footer")
  .addService(googletag.pubads())
  .setTargeting("pos", "btf")
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([1018, 0], [970, 66])
  .addSize([0, 0], [320, 50])
  .build();
googletag.slots["header"] = googletag.defineSlot("/30582678/OMG/yourobserver/black-tie/black-tie", [[970, 66], [320, 50]], "dfp-ad-header")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf")
  .defineSizeMapping(mapping);</script>
<script>googletag.slots["photo_gallery"] = googletag.defineSlot("/30582678/OMG/yourobserver/black-tie/black-tie", [300, 250], "dfp-ad-photo_gallery")
  .addService(googletag.pubads())
  .setTargeting("pos", "atf");</script>
<script>googletag.slots["stacked_top"] = googletag.defineSlot("/30582678/OMG/yourobserver/black-tie/black-tie", [300, 250], "dfp-ad-stacked_top")
  .addService(googletag.pubads())
  .setTargeting("pos", "stf");</script>
<script>googletag.slots["stacked_bottom"] = googletag.defineSlot("/30582678/OMG/yourobserver/black-tie/black-tie", [300, 250], "dfp-ad-stacked_bottom")
  .addService(googletag.pubads())
  .setTargeting("pos", "btf");</script>
<script>googletag.slots["sticky_footer"] = googletag.defineOutOfPageSlot("/30582678/OMG/yourobserver/black-tie/black-tie", "dfp-ad-sticky_footer")
  .addService(googletag.pubads());</script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
  googletag.pubads().setTargeting("ob_paper", "Black Tie");
  googletag.pubads().setTargeting("ob_section", "Black Tie");
  googletag.pubads().setTargeting("hostname", "www.yourobserver.com");
  googletag.pubads().setTargeting("url_arg_0", "photo-gallery");
  googletag.pubads().setTargeting("url_arg_1", "ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki");
  googletag.pubads().setTargeting("ob_type", "Photo Gallery");
  googletag.pubads().setTargeting("page-type", "Photo Gallery");
  googletag.pubads().setTargeting("page-type", "photo-gallery");
});

googletag.enableServices();</script>
<script src="https://www.yourobserver.com/sites/default/files/js/js_sPs3qC2DCHnpZKpHDXDUut4jzWIwoi_tESy9OiNzFIM.js"></script>
<script>jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"yourobserver","theme_token":"Af1AltoUu64oslgMQ_yqMDj9xITJ2xv-13q2deic6ro","js":{"\/sites\/all\/modules\/custom\/tog_most_popular\/js\/tog_most_popular_track.js":1,"sites\/all\/themes\/yourobserver\/scripts\/dist\/app.js":1,"sites\/all\/themes\/yourobserver\/scripts\/ads.js":1,"\/sites\/all\/modules\/custom\/tog_most_popular\/js\/tog_most_popular.js":1,"\/sites\/all\/modules\/features\/tog_planned_story\/js\/tog_planned_story_share.js":1,"\/sites\/all\/modules\/features\/tog_planned_story\/js\/tog_planned_story_related.js":1,"\/sites\/all\/modules\/features\/tog_people\/js\/tog_people_stories.js":1,"\/sites\/all\/modules\/features\/tog_planned_story\/js\/tog_planned_story_disqus.js":1,"public:\/\/google_tag\/google_tag.script.js":1,"\/\/ajax.googleapis.com\/ajax\/libs\/jquery\/1.9.1\/jquery.min.js":1,"0":1,"misc\/jquery.once.js":1,"1":1,"https:\/\/www.googletagservices.com\/tag\/js\/gpt.js":1,"misc\/drupal.js":1,"2":1,"3":1,"4":1,"5":1,"6":1,"7":1,"8":1,"sites\/all\/modules\/contrib\/disqus\/disqus.js":1,"sites\/all\/modules\/contrib\/datalayer\/datalayer.js":1,"sites\/all\/themes\/yourobserver\/scripts\/dist\/modernizr.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/comment\/comment.css":1,"sites\/all\/modules\/contrib\/date\/date_api\/date.css":1,"sites\/all\/modules\/contrib\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/contrib\/logintoboggan\/logintoboggan.css":1,"sites\/all\/modules\/contrib\/mollom\/mollom.css":1,"modules\/node\/node.css":1,"modules\/search\/search.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/contrib\/views\/css\/views.css":1,"sites\/all\/modules\/contrib\/ctools\/css\/ctools.css":1,"sites\/all\/themes\/yourobserver\/css\/style.css":1,"sites\/all\/themes\/mothership\/mothership\/mothership\/css\/normalize.css":1,"sites\/all\/themes\/mothership\/mothership\/mothership\/css\/mothership-default.css":1,"sites\/all\/themes\/mothership\/mothership\/mothership\/css\/mothership-layout.css":1,"sites\/all\/themes\/mothership\/mothership\/mothership\/css\/mothership.css":1,"sites\/all\/themes\/yourobserver\/system.messages.css":1,"sites\/all\/themes\/yourobserver\/comment.css":1,"sites\/all\/themes\/yourobserver\/node.css":1,"sites\/all\/themes\/yourobserver\/mothership.css":1,"sites\/all\/themes\/yourobserver\/mothership-layout.css":1,"sites\/all\/themes\/yourobserver\/mothership-default.css":1,"sites\/all\/themes\/yourobserver\/normalize.css":1,"sites\/all\/themes\/yourobserver\/mothership-devel-mediaqueries.css":1,"sites\/all\/themes\/yourobserver\/reset-html5.css":1,"sites\/all\/themes\/yourobserver\/contextual.css":1,"sites\/all\/themes\/yourobserver\/reset.css":1,"sites\/all\/themes\/yourobserver\/views.css":1,"sites\/all\/themes\/yourobserver\/date.css":1,"sites\/all\/themes\/yourobserver\/system.menus.css":1,"sites\/all\/themes\/yourobserver\/system.theme.css":1,"sites\/all\/themes\/yourobserver\/date_views.css":1,"sites\/all\/themes\/yourobserver\/adaptive-image.css":1}},"author_id":"59764","ps_nid":"209669","ps_pub_id":"259","ps_sec_id":"all","ps_type_id":"all","ps_node_type":"planned_story","track_nid":"209669","urlIsAjaxTrusted":{"\/photo-gallery\/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki":true},"ad_page_type":"people","ad_slot_top":"half_page","ad_slot_bottom":"stacked_bottom","disqus":{"domain":"yourobserver","url":"https:\/\/www.yourobserver.com\/photo-gallery\/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki","title":"AJC\u2019s 2017 Civic Achievement Award Dinner honors Jennifer Rominiecki","identifier":"yourobserver\/209669"},"dataLayer":{"languages":{"en":{"language":"en","name":"English","native":"English","direction":0,"enabled":1,"plurals":0,"formula":"","domain":"","prefix":"","weight":0,"javascript":""}}},"password":{"strengthTitle":"Password compliance:"},"type":"setting"});</script>

  </head>

  <body class="not-front no-sidebars node-type-planned-story no--top-ad no--footer-ad" >

  
  <a href="#content--wrapper" class="element-invisible element-focusable">
    Skip to main content  </a>

  
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TK5NRZ" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  

  <header class="main-header" role="banner">
      <div class="site--header bg--red">

  <div class="nav--top">
    <a href="/" title="Home" rel="home" class="logo">
      <img src="/sites/all/themes/yourobserver/images/logos/logo-bright.svg" alt="Home" />
    </a>
    <div class="right-nav right">
      <div class="secondary-nav">
      	<ul class="links"><li class="first leaf item-wrapper-level-1 item-1877-wrap"><a href="http://www.businessobserverfl.com/" class="item-1877 item-level-1">Business</a></li>
<li class="leaf item-wrapper-level-1 item-1876-wrap"><a href="/calendar" class="item-1876 item-level-1">Calendar</a></li>
<li class="leaf item-wrapper-level-1 item-1183-wrap"><a href="/lists/all/real-estate/all" class="item-1183 item-level-1">Real Estate</a></li>
<li class="leaf item-wrapper-level-1 item-1198-wrap"><a href="http://classifieds.yourobserver.com/" class="item-1198 item-level-1">Classifieds</a></li>
<li class="collapsed item-wrapper-level-1 item-1199-wrap"><a href="/contests" class="item-1199 item-level-1">Contests</a></li>
<li class="last leaf item-wrapper-level-1 item-1184-wrap"><a href="/e-editions?publication=220" class="item-1184 item-level-1">E-Edition</a></li>
</ul>      </div>
      <div id="weather" class="header-module--weather bg--light-red">
        <span class="icon moon-icon "></span><span class="temp">66</span>
        <span class="date right"></span>
      </div>
    </div>

    <span class="mobile-trigger search mobile--only" data-class="search">
      <span class="icon search-icon"></span>
    </span>
    <span class="mobile-trigger close-search mobile--only" data-class="search">
      <span class="icon close-icon"></span>
    </span>
    <div class="mobile-trigger menu mobile--only" data-class="menu">
      <span class="icon menu-icon"></span>
    </div>

    <div class="header-search mobile--only">
      <form action="/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki" method="post" id="search-block-form" accept-charset="UTF-8">
  <h2 class="element-invisible">Search form</h2>

<div>
  <label class="element-invisible" for="edit-search-block-form--2">Search</label>
 <input title="Enter the terms you wish to search for." placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="30" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" /></div><input type="hidden" name="form_build_id" value="form-A2iAZRlWwi-D9IjAnB7gn7Ph4pOjxh2TwtJq_RLi0PU" />
<input type="hidden" name="form_id" value="search_block_form" />
</form>    </div>

  </div>

  <div class="nav--bottom sticky-container">
    <div class="bg--dark-red sticky" data-margin="0" data-position="fixed">
      <div class="container">
        <a class="logo" href="/" title="Home" rel="home" class="logo">
          <img class="full" src="/sites/all/themes/yourobserver/images/logos/logo-white.svg" alt="Your Observer">
        </a>
        <nav class="site--main-nav" data-prepend=".right-nav" data-original=".nav--bottom .container">
          <ul class="links"><li class="first expanded item-wrapper-level-1 item-1135-wrap"><a href="/longboat-key" class="item-1135 item-level-1">Longboat Key</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1164-wrap"><a href="/lists/longboat-key/news/all" class="item-1164 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1165-wrap"><a href="/lists/longboat-key/opinion/all" class="item-1165 item-level-2"><span class="icon i-arrow-right-small"></span> Opinion</a></li>
<li class="leaf item-wrapper-level-2 item-1166-wrap"><a href="/lists/longboat-key/religion/all" class="item-1166 item-level-2"><span class="icon i-arrow-right-small"></span> Religion</a></li>
<li class="leaf item-wrapper-level-2 item-1170-wrap"><a href="/lists/longboat-key/cops-corner/all" class="item-1170 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1167-wrap"><a href="/lists/longboat-key/sports/all" class="item-1167 item-level-2"><span class="icon i-arrow-right-small"></span> Sports</a></li>
<li class="leaf item-wrapper-level-2 item-1168-wrap"><a href="/lists/longboat-key/neighbors/all" class="item-1168 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1263-wrap"><a href="/lists/longboat-key/business/all" class="item-1263 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="leaf item-wrapper-level-2 item-1265-wrap"><a href="/lists/longboat-key/real-estate/all" class="item-1265 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
<li class="leaf item-wrapper-level-2 item-1262-wrap"><a href="/lists/longboat-key/your-town/all" class="item-1262 item-level-2"><span class="icon i-arrow-right-small"></span> Your Town</a></li>
<li class="last leaf item-wrapper-level-2 item-1839-wrap"><a href="https://www.yourobserver.com/lists/all/health/all" class="item-1839 item-level-2"><span class="icon i-arrow-right-small"></span> Health</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1137-wrap"><a href="/east-county" class="item-1137 item-level-1">East County</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1173-wrap"><a href="/lists/east-county/news/all" class="item-1173 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1175-wrap"><a href="/lists/east-county/religion/all" class="item-1175 item-level-2"><span class="icon i-arrow-right-small"></span> Religion</a></li>
<li class="leaf item-wrapper-level-2 item-1177-wrap"><a href="/lists/east-county/cops-corner/all" class="item-1177 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1179-wrap"><a href="/lists/east-county/sports/all" class="item-1179 item-level-2"><span class="icon i-arrow-right-small"></span> Sports</a></li>
<li class="leaf item-wrapper-level-2 item-1267-wrap"><a href="/lists/east-county/neighbors/all" class="item-1267 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1180-wrap"><a href="/lists/east-county/schools/all" class="item-1180 item-level-2"><span class="icon i-arrow-right-small"></span> Schools</a></li>
<li class="leaf item-wrapper-level-2 item-1268-wrap"><a href="/lists/east-county/business/all" class="item-1268 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="leaf item-wrapper-level-2 item-1266-wrap"><a href="/lists/east-county/real-estate/all" class="item-1266 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
<li class="leaf item-wrapper-level-2 item-1269-wrap"><a href="/lists/east-county/your-town/all" class="item-1269 item-level-2"><span class="icon i-arrow-right-small"></span> Your Town</a></li>
<li class="leaf item-wrapper-level-2 item-1840-wrap"><a href="https://www.yourobserver.com/lists/all/health/all" class="item-1840 item-level-2"><span class="icon i-arrow-right-small"></span> Health</a></li>
<li class="last leaf item-wrapper-level-2 item-1698-wrap"><a href="http://www.lwrlifemagazine.com/" class="item-1698 item-level-2"><span class="icon i-arrow-right-small"></span> LWR Life Magazine</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1136-wrap"><a href="/sarasota" class="item-1136 item-level-1">Sarasota</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1149-wrap"><a href="/lists/sarasota/news/all" class="item-1149 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1150-wrap"><a href="/lists/sarasota/opinion/all" class="item-1150 item-level-2"><span class="icon i-arrow-right-small"></span> Opinion</a></li>
<li class="leaf item-wrapper-level-2 item-1276-wrap"><a href="/lists/sarasota/religion/all" class="item-1276 item-level-2"><span class="icon i-arrow-right-small"></span> Religion</a></li>
<li class="leaf item-wrapper-level-2 item-1145-wrap"><a href="/lists/sarasota/cops-corner/all" class="item-1145 item-level-2"><span class="icon i-arrow-right-small"></span> Cops Corner</a></li>
<li class="leaf item-wrapper-level-2 item-1272-wrap"><a href="/lists/sarasota/sports/all" class="item-1272 item-level-2"><span class="icon i-arrow-right-small"></span> Sports</a></li>
<li class="leaf item-wrapper-level-2 item-1148-wrap"><a href="/lists/sarasota/neighbors/all" class="item-1148 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1271-wrap"><a href="/lists/sarasota/schools/all" class="item-1271 item-level-2"><span class="icon i-arrow-right-small"></span> Schools</a></li>
<li class="leaf item-wrapper-level-2 item-1273-wrap"><a href="/lists/sarasota/business/all" class="item-1273 item-level-2"><span class="icon i-arrow-right-small"></span> Business</a></li>
<li class="leaf item-wrapper-level-2 item-1274-wrap"><a href="/lists/sarasota/real-estate/all" class="item-1274 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
<li class="leaf item-wrapper-level-2 item-1275-wrap"><a href="/lists/sarasota/your-town/all" class="item-1275 item-level-2"><span class="icon i-arrow-right-small"></span> Your Town</a></li>
<li class="last leaf item-wrapper-level-2 item-1841-wrap"><a href="https://www.yourobserver.com/lists/all/health/all" class="item-1841 item-level-2"><span class="icon i-arrow-right-small"></span> Health</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1032-wrap"><a href="/siesta-key" class="item-1032 item-level-1">Siesta Key</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1160-wrap"><a href="/lists/siesta-key/news/all" class="item-1160 item-level-2"><span class="icon i-arrow-right-small"></span> News</a></li>
<li class="leaf item-wrapper-level-2 item-1277-wrap"><a href="/lists/siesta-key/religion/all" class="item-1277 item-level-2"><span class="icon i-arrow-right-small"></span> Religion</a></li>
<li class="leaf item-wrapper-level-2 item-1162-wrap"><a href="/lists/siesta-key/neighbors/all" class="item-1162 item-level-2"><span class="icon i-arrow-right-small"></span> Neighbors</a></li>
<li class="leaf item-wrapper-level-2 item-1280-wrap"><a href="/lists/sarasota/real-estate/all" class="item-1280 item-level-2"><span class="icon i-arrow-right-small"></span> Real Estate</a></li>
<li class="leaf item-wrapper-level-2 item-1281-wrap"><a href="/lists/siesta-key/your-town/all" class="item-1281 item-level-2"><span class="icon i-arrow-right-small"></span> Your Town</a></li>
<li class="last leaf item-wrapper-level-2 item-1842-wrap"><a href="https://www.yourobserver.com/lists/all/health/all" class="item-1842 item-level-2"><span class="icon i-arrow-right-small"></span> Health</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1284-wrap"><a href="/arts-and-entertainment" class="item-1284 item-level-1">Arts & Entertainment</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1855-wrap"><a href="/lists/arts-and-entertainment/eat-and-drink/all" class="item-1855 item-level-2"><span class="icon i-arrow-right-small"></span> Eat & Drink</a></li>
<li class="leaf item-wrapper-level-2 item-1476-wrap"><a href="/lists/arts-and-entertainment/music/all" class="item-1476 item-level-2"><span class="icon i-arrow-right-small"></span> Music</a></li>
<li class="leaf item-wrapper-level-2 item-1478-wrap"><a href="/lists/arts-and-entertainment/visual-art/all" class="item-1478 item-level-2"><span class="icon i-arrow-right-small"></span> Visual Art</a></li>
<li class="leaf item-wrapper-level-2 item-1479-wrap"><a href="/lists/arts-and-entertainment/performing-art/all" class="item-1479 item-level-2"><span class="icon i-arrow-right-small"></span> Performing Art</a></li>
<li class="leaf item-wrapper-level-2 item-1480-wrap"><a href="/lists/arts-and-entertainment/this-week/all" class="item-1480 item-level-2"><span class="icon i-arrow-right-small"></span> This Week</a></li>
<li class="leaf item-wrapper-level-2 item-1481-wrap"><a href="/photo-galleries/arts-and-entertainment/all" class="item-1481 item-level-2"><span class="icon i-arrow-right-small"></span> Photos</a></li>
<li class="leaf item-wrapper-level-2 item-1482-wrap"><a href="/videos/arts-and-entertainment/all" class="item-1482 item-level-2"><span class="icon i-arrow-right-small"></span> Videos</a></li>
<li class="leaf item-wrapper-level-2 item-1483-wrap"><a href="/lists/arts-and-entertainment/reviews/all" class="item-1483 item-level-2"><span class="icon i-arrow-right-small"></span> Reviews</a></li>
<li class="leaf item-wrapper-level-2 item-1320-wrap"><a href="https://www.yourobserver.com/in-the-kitchen" class="item-1320 item-level-2"><span class="icon i-arrow-right-small"></span> In the Kitchen</a></li>
<li class="last leaf item-wrapper-level-2 item-1875-wrap"><a href="/arts-and-entertainment/calendar" class="item-1875 item-level-2"><span class="icon i-arrow-right-small"></span> A & E Calendar</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1141-wrap"><a href="/black-tie" class="item-1141 item-level-1">Black Tie</a><ul class="sub-menu sub-level-2"><li class="first leaf item-wrapper-level-2 item-1489-wrap"><a href="/black-tie-social-calendar" class="item-1489 item-level-2"><span class="icon i-arrow-right-small"></span> Social Calendar</a></li>
<li class="leaf item-wrapper-level-2 item-1854-wrap"><a href="/lists/black-tie/black-tie-and-tales/all" class="item-1854 item-level-2"><span class="icon i-arrow-right-small"></span> Black Tie & Tales</a></li>
<li class="leaf item-wrapper-level-2 item-1918-wrap"><a href="/lists/black-tie/familiar-faces/all" class="item-1918 item-level-2"><span class="icon i-arrow-right-small"></span> Familiar Faces</a></li>
<li class="leaf item-wrapper-level-2 item-1492-wrap"><a href="/lists/black-tie/fashion/all" class="item-1492 item-level-2"><span class="icon i-arrow-right-small"></span> Fashion</a></li>
<li class="leaf item-wrapper-level-2 item-1493-wrap"><a href="/lists/black-tie/just-married/all" class="item-1493 item-level-2"><span class="icon i-arrow-right-small"></span> Just Married</a></li>
<li class="last leaf item-wrapper-level-2 item-1697-wrap"><a href="/photo-galleries/black-tie/all" class="item-1697 item-level-2"><span class="icon i-arrow-right-small"></span> Photos</a></li>
</ul></li>
<li class="expanded item-wrapper-level-1 item-1255-wrap"><a href="/photo-galleries/all/all" class="item-1255 item-level-1">Photos</a><ul class="sub-menu sub-level-2"><li class="first last leaf item-wrapper-level-2 item-1903-wrap"><a href="/photos" class="item-1903 item-level-2"><span class="icon i-arrow-right-small"></span> Search Photos</a></li>
</ul></li>
<li class="last leaf item-wrapper-level-1 item-1256-wrap"><a href="/videos/all/all" class="item-1256 item-level-1">Videos</a></li>
</ul>        </nav>
      </div>

      <div class="header-search">
        <span class="icon close-icon"></span>
        <form action="/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki" method="post" id="search-block-form" accept-charset="UTF-8">
  <h2 class="element-invisible">Search form</h2>

<div>
  <label class="element-invisible" for="edit-search-block-form--2">Search</label>
 <input title="Enter the terms you wish to search for." placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="30" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" /></div><input type="hidden" name="form_build_id" value="form-A2iAZRlWwi-D9IjAnB7gn7Ph4pOjxh2TwtJq_RLi0PU" />
<input type="hidden" name="form_id" value="search_block_form" />
</form>      </div>
    </div>
  </div>

</div>
  </header>

  <div id="header_ad" class="advert-bar advert-bar--header bg--mild-grey">
    <div class="advert-wrapper">
      <div id="dfp-ad-header-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-header" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-header");
      });
  </script>
</div>
</div>    </div>
  </div>

<div class="page-wrapper">

      
      
      
      
    <div class="module--slider synced header--full has--image">

    <span class="gen-loader gallery-loading">Loading Gallery...</span>

    <div class="sync-1 rsDefault large">
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143035_standard.jpeg?itok=Y62OqSFp" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143035_standard.jpeg" title="Chairwoman Jean Weidner-Goldstein, Award Winner Jennifer Rominiecki, Chairwoman Gerri Aaron and Teri Hansen" alt="Chairwoman Jean Weidner-Goldstein, Award Winner Jennifer Rominiecki, Chairwoman Gerri Aaron and Teri Hansen">Chairwoman Jean Weidner-Goldstein, Award Winner Jennifer Rominiecki, Chairwoman Gerri Aaron and Teri Hansen<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143035_standard.jpeg?itok=T00kr3wH" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <h1 class="title zeta">AJC’s 2017 Civic Achievement Award Dinner honors Jennifer Rominiecki</h1>
                          <p>Friday, Nov. 17, 2017 | </p><h2> Chairwoman Jean Weidner-Goldstein, Award Winner Jennifer Rominiecki, Chairwoman Gerri Aaron and Teri Hansen</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143035_standard.jpeg%3Fitok%3DtF3rtFmB&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7cf833707/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143041_standard.jpeg?itok=PLfN7ZAR" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143041_standard.jpeg" title="Marlene and Hal Liberman" alt="Marlene and Hal Liberman">Marlene and Hal Liberman<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143041_standard.jpeg?itok=zEoO3fwF" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Marlene and Hal Liberman</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143041_standard.jpeg%3Fitok%3DpL4Bgo7X&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7d9071034/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143040_standard.jpeg?itok=nljYwfGx" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143040_standard.jpeg" title="Barbara Brizdle, Sumner Baum and Marilyn Shuman" alt="Barbara Brizdle, Sumner Baum and Marilyn Shuman">Barbara Brizdle, Sumner Baum and Marilyn Shuman<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143040_standard.jpeg?itok=J8Zv3D7S" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Barbara Brizdle, Sumner Baum and Marilyn Shuman</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143040_standard.jpeg%3Fitok%3DPz5J_b_A&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7d70e42b8/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143037_standard.jpeg?itok=AdoXGlLR" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143037_standard.jpeg" title="AJC Regional Director Brian Lipton, Award Winner Jennifer Rominiecki and  AJC Regional President Anne Virag" alt="AJC Regional Director Brian Lipton, Award Winner Jennifer Rominiecki and  AJC Regional President Anne Virag">AJC Regional Director Brian Lipton, Award Winner Jennifer Rominiecki and  AJC Regional President Anne Virag<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143037_standard.jpeg?itok=NlpAOBsa" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> AJC Regional Director Brian Lipton, Award Winner Jennifer Rominiecki and  AJC Regional President Anne Virag</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143037_standard.jpeg%3Fitok%3DYTnTQ0VP&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7d1fcb883/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143042_standard.jpeg?itok=sJBIN43q" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143042_standard.jpeg" title="Fran and Jack Braverman with Alan Bandler and Ken Newmark" alt="Fran and Jack Braverman with Alan Bandler and Ken Newmark">Fran and Jack Braverman with Alan Bandler and Ken Newmark<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143042_standard.jpeg?itok=Bw6hhl7Y" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Fran and Jack Braverman with Alan Bandler and Ken Newmark</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143042_standard.jpeg%3Fitok%3DSYYRoYHT&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7db6636d3/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143036_standard.jpeg?itok=lzl1C6_r" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143036_standard.jpeg" title="Rob, Noah, Honoree Jennifer and Luke Rominiecki" alt="Rob, Noah, Honoree Jennifer and Luke Rominiecki">Rob, Noah, Honoree Jennifer and Luke Rominiecki<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143036_standard.jpeg?itok=c_9_UjAU" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Rob, Noah, Honoree Jennifer and Luke Rominiecki</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143036_standard.jpeg%3Fitok%3Deb9z7fKH&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7d0bd24af/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143043_standard.jpeg?itok=q9nC3mxE" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143043_standard.jpeg" title="James La Porte and Steven Krause" alt="James La Porte and Steven Krause">James La Porte and Steven Krause<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143043_standard.jpeg?itok=wceJmNg1" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> James La Porte and Steven Krause</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143043_standard.jpeg%3Fitok%3DuwP8M2nD&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7dd1f264d/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143044_standard.jpeg?itok=MNxq8q7z" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143044_standard.jpeg" title="Margaret Wise and Flora Major" alt="Margaret Wise and Flora Major">Margaret Wise and Flora Major<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143044_standard.jpeg?itok=oJ5zPBkN" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Margaret Wise and Flora Major</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143044_standard.jpeg%3Fitok%3D_LMp-E5T&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7debbb3b3/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143038_standard.jpeg?itok=WEQChI4q" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143038_standard.jpeg" title="Guests were greeted by colorful table decor at the dinner." alt="Guests were greeted by colorful table decor at the dinner.">Guests were greeted by colorful table decor at the dinner.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143038_standard.jpeg?itok=2R6d9HcK" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Guests were greeted by colorful table decor at the dinner.</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143038_standard.jpeg%3Fitok%3D9BfUyDZj&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7d32d899d/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143045_standard.jpeg?itok=ICgUi8zl" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143045_standard.jpeg" title="Mischa Kirby, Barbara Hansen and Jeannie Perales" alt="Mischa Kirby, Barbara Hansen and Jeannie Perales">Mischa Kirby, Barbara Hansen and Jeannie Perales<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143045_standard.jpeg?itok=fVYyiCLH" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Mischa Kirby, Barbara Hansen and Jeannie Perales</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143045_standard.jpeg%3Fitok%3DliMSYCNU&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7e05d0c48/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143046_standard.jpeg?itok=n65WmHF9" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143046_standard.jpeg" title="Maria Camacho and Joseph Gianguzzo" alt="Maria Camacho and Joseph Gianguzzo">Maria Camacho and Joseph Gianguzzo<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143046_standard.jpeg?itok=YdQRorJR" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Maria Camacho and Joseph Gianguzzo</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143046_standard.jpeg%3Fitok%3DvVpM-KOd&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7e1e221af/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143039_standard.jpeg?itok=e3zTH-tA" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143039_standard.jpeg" title="Guests were greeted by colorful table decor at the dinner." alt="Guests were greeted by colorful table decor at the dinner.">Guests were greeted by colorful table decor at the dinner.<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143039_standard.jpeg?itok=m9TzcohC" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Guests were greeted by colorful table decor at the dinner.</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143039_standard.jpeg%3Fitok%3DqhzWFbKg&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7d4bbbcf6/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143047_standard.jpeg?itok=b2sZ5NNl" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143047_standard.jpeg" title="Sandy Hayden and Edie Chaifetz" alt="Sandy Hayden and Edie Chaifetz">Sandy Hayden and Edie Chaifetz<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143047_standard.jpeg?itok=RGY7Dl5v" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Sandy Hayden and Edie Chaifetz</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143047_standard.jpeg%3Fitok%3DP1kfFjjz&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7e35ae790/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143048_standard.jpeg?itok=59gySaUu" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143048_standard.jpeg" title="Phil King and Nelle Miller" alt="Phil King and Nelle Miller">Phil King and Nelle Miller<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143048_standard.jpeg?itok=AIynFjkL" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Phil King and Nelle Miller</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143048_standard.jpeg%3Fitok%3D51xn9z_Y&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7e4c74850/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143049_standard.jpeg?itok=Vu3dzX54" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143049_standard.jpeg" title="Sally Yanowitz and Hermione Gilpin" alt="Sally Yanowitz and Hermione Gilpin">Sally Yanowitz and Hermione Gilpin<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143049_standard.jpeg?itok=CQ347tmO" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Sally Yanowitz and Hermione Gilpin</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143049_standard.jpeg%3Fitok%3DziV5_Rtv&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7e628f816/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143050_standard.jpeg?itok=C6OuK-YN" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143050_standard.jpeg" title="Ivan Kushen, Abe Ostrovsky, Christine Hughes, Mort Siegel and Marilyn Kushen" alt="Ivan Kushen, Abe Ostrovsky, Christine Hughes, Mort Siegel and Marilyn Kushen">Ivan Kushen, Abe Ostrovsky, Christine Hughes, Mort Siegel and Marilyn Kushen<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143050_standard.jpeg?itok=72nmpCGr" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Ivan Kushen, Abe Ostrovsky, Christine Hughes, Mort Siegel and Marilyn Kushen</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143050_standard.jpeg%3Fitok%3DjRvQT3Zl&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7e7b42bbb/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143051_standard.jpeg?itok=knOx6F2H" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143051_standard.jpeg" title="Valerie and Emma Joels" alt="Valerie and Emma Joels">Valerie and Emma Joels<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143051_standard.jpeg?itok=rKiKeOha" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Valerie and Emma Joels</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143051_standard.jpeg%3Fitok%3Doy313ZP9&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7e93a36dd/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143052_standard.jpeg?itok=TbLRYtCi" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143052_standard.jpeg" title="Sally Schule and Heidi Brown" alt="Sally Schule and Heidi Brown">Sally Schule and Heidi Brown<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143052_standard.jpeg?itok=SY5Tl31U" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Sally Schule and Heidi Brown</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143052_standard.jpeg%3Fitok%3DG4HR83sW&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7eab59ce1/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143053_standard.jpeg?itok=9UfLksHH" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143053_standard.jpeg" title="Maryanne Young and Barbara Feldman" alt="Maryanne Young and Barbara Feldman">Maryanne Young and Barbara Feldman<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143053_standard.jpeg?itok=0pIf7UJT" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Maryanne Young and Barbara Feldman</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143053_standard.jpeg%3Fitok%3DMqHU5urP&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7ec1d70a6/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143054_standard.jpeg?itok=NJ_0JOiW" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143054_standard.jpeg" title="Michael Brown, Isabelle Norton, Carolyn Johnson and Meg Lowman" alt="Michael Brown, Isabelle Norton, Carolyn Johnson and Meg Lowman">Michael Brown, Isabelle Norton, Carolyn Johnson and Meg Lowman<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143054_standard.jpeg?itok=CxqRqbTX" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Michael Brown, Isabelle Norton, Carolyn Johnson and Meg Lowman</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143054_standard.jpeg%3Fitok%3D0dZOip39&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7edb66d70/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143063_standard.jpeg?itok=q0ubiNEh" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143063_standard.jpeg" title="AJC Regional Director Brian Lipton claps for Award Winner Jennifer Rominiecki" alt="AJC Regional Director Brian Lipton claps for Award Winner Jennifer Rominiecki">AJC Regional Director Brian Lipton claps for Award Winner Jennifer Rominiecki<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143063_standard.jpeg?itok=HxTLZsG7" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> AJC Regional Director Brian Lipton claps for Award Winner Jennifer Rominiecki</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143063_standard.jpeg%3Fitok%3DBA0gGUs7&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f803ab68e7/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143057_standard.jpeg?itok=v7Buad6f" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143057_standard.jpeg" title="Ilene Fox and Gisele Pintchuck" alt="Ilene Fox and Gisele Pintchuck">Ilene Fox and Gisele Pintchuck<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143057_standard.jpeg?itok=_Z_eFMUA" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Ilene Fox and Gisele Pintchuck</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143057_standard.jpeg%3Fitok%3Dw2tOUAHz&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7f9b872ba/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143058_standard.jpeg?itok=RiMlh3Hg" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143058_standard.jpeg" title="Graci McGillicuddy with Tom and Debbie Trimble" alt="Graci McGillicuddy with Tom and Debbie Trimble">Graci McGillicuddy with Tom and Debbie Trimble<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143058_standard.jpeg?itok=Wenetd12" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Graci McGillicuddy with Tom and Debbie Trimble</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143058_standard.jpeg%3Fitok%3Dc8wNmWdK&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7fb3b453b/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143059_standard.jpeg?itok=1iv321UL" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143059_standard.jpeg" title="Shawn and Wendy Egen" alt="Shawn and Wendy Egen">Shawn and Wendy Egen<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143059_standard.jpeg?itok=-bChJiSm" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Shawn and Wendy Egen</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143059_standard.jpeg%3Fitok%3DN9480CKq&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7fcad3ac2/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143060_standard.jpeg?itok=LvMxCdjf" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143060_standard.jpeg" title="Veronica Brady and Skip Sach" alt="Veronica Brady and Skip Sach">Veronica Brady and Skip Sach<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143060_standard.jpeg?itok=W_sniiLo" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Veronica Brady and Skip Sach</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143060_standard.jpeg%3Fitok%3D7R1LhASN&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f7fe4a1739/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143061_standard.jpeg?itok=6-dawQa8" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143061_standard.jpeg" title="Margie and Chuck Barancik" alt="Margie and Chuck Barancik">Margie and Chuck Barancik<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143061_standard.jpeg?itok=zn5_DYDh" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Margie and Chuck Barancik</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143061_standard.jpeg%3Fitok%3DjKFi1yh3&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f80032787b/original.jpg">Buy this Photo</a>
                        </div>
        </div>
              <div class="contain small">

          <a class="rsImg" href="https://www.yourobserver.com/sites/default/files/styles/sliders_and_planned_story_image_870x580/public/143062_standard.jpeg?itok=mGSjx1A1" data-rsBigImg="https://www.yourobserver.com/sites/default/files/143062_standard.jpeg" title="Harriett Bernbaum, Toby Siegel and Kim Metz" alt="Harriett Bernbaum, Toby Siegel and Kim Metz">Harriett Bernbaum, Toby Siegel and Kim Metz<img src="https://www.yourobserver.com/sites/default/files/styles/thumbnails_gallery_header_100x100/public/143062_standard.jpeg?itok=mJsEZs3T" class="rsTmb lazy" /></a>


          <div class="contain caption rsCaption">
                          <p>Friday, Nov. 17, 2017 | </p><h2> Harriett Bernbaum, Toby Siegel and Kim Metz</h2>
                              <a class="buy-photo" target="_blank" href="http://yourobserver.mycapture.com/mycapture/remoteimage.asp?backtext=Click%20here%20to%20return%20to%20gallery&backurl=https%3A//www.yourobserver.com/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&image=https%3A//www.yourobserver.com/sites/default/files/styles/for_sale_580x386/public/143062_standard.jpeg%3Fitok%3DQzjmbpcg&notes=https%3A//omg-cws-prod.s3.amazonaws.com/photo/37407/5a0f80220046a/original.jpg">Buy this Photo</a>
                        </div>
        </div>
          </div>

    <div class="module--slider-nav">
      <span id="prev-image" class="icon arrow-left-icon prev" data-direction="prev"></span>
      <span id="next-image" class="icon arrow-right-icon next" data-direction="next"></span>
    </div>

    <span class="icon expand-icon zeta"></span>

    <div class="ad-container">
      <div id="dfp-ad-photo_gallery-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-photo_gallery" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-photo_gallery");
      });
  </script>
</div>
</div>    </div>

  </div> <!-- sync-slider -->



<main class="section overflow-sticky">
  <div class="container large">
    <div class="col-2-3 page-content">
      <article about="/photo-gallery/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki" typeof="sioc:Item foaf:Document" class="photo-gallery">

      
        <div class="overflow-sticky">
                              <div class="sticky-container">
           <div class="article-social-bar sticky bg--lightest-grey" data-margin="nav" data-position="absolute">
              <span class="label text--red">Share</span>
              <ul class="social-icons">
                              <li>
                  <a href="# " data-social="{&quot;type&quot;:&quot;facebook&quot;,&quot;url&quot;:&quot;https:\/\/www.yourobserver.com\/photo-gallery\/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&quot;,&quot;text&quot;:&quot;AJC\u2019s 2017 Civic Achievement Award Dinner honors Jennifer Rominiecki&quot;}" class="link social-share"><span class="icon facebook-icon"></span></a>                </li>
                                            <li>
                  <a href="# " data-social="{&quot;type&quot;:&quot;twitter&quot;,&quot;url&quot;:&quot;https:\/\/www.yourobserver.com\/photo-gallery\/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki&quot;,&quot;text&quot;:&quot;AJC\u2019s 2017 Civic Achievement Award Dinner honors Jennifer Rominiecki&quot;}" class="link social-share"><span class="icon twitter-icon"></span></a>                </li>
                              <li>
                  <a href="/cdn-cgi/l/email-protection#79465f0a0c1b131c1a0d44361b0a1c0b0f1c0b5c4b49341c1d10185c4b493e0b160c095c4b49545c4b4938333a9bf9e00a594b49484e593a100f101a59381a11101c0f1c141c170d59380e180b1d593d1017171c0b59111617160b0a59331c1717101f1c0b592b16141017101c1a12105f1b161d0044110d0d090a4356560e0e0e5700160c0b161b0a1c0b0f1c0b571a1614560911160d16541e1815151c0b005618131a0a544b49484e541a100f101a54181a11101c0f1c141c170d54180e180b1d541d1017171c0b54111617160b0a54131c1717101f1c0b540b16141017101c1a1210" target="_top" class="" title="Email This Page">
                    <span class="icon mail-icon"></span>
                  </a>
                </li>
              </ul>
              <a id="ps_disqus" href="#disqus_thread" class="comments right scrollto" data-scroll-target="disqus"></a>
           </div>
          </div>

                      <h6 class="dek left-margin">




  The annual award dinner recognized the president and CEO of Marie Selby Botanical Gardens on Nov. 16 at Michael’s On East.


</h6>
          
                                    




  <div class="author left-margin">
	by: 
	<a href="/articles/author/niki-kottmann" title="See All Articles by Niki Kottmann" class="text--red">
		




  Niki Kottmann


	</a>
	<span>




  Managing Editor of Arts and Entertainment


</span>
</div>



                      


          <div id="content--wrapper" class="content--wrapper">
            <div class="p402_premium">
              




  <p>Anyone who&rsquo;s ever set foot at a Marie Selby Botanical Gardens event knows the distinctive style of a Roger Capote-designed event, and the annual AJC Civic Achievement Award Dinner had the same feel this year.</p>

<p>Capote brought the colorful spirit of the gardens to the ballroom on Nov. 16 at Michael&rsquo;s On East to help AJC West Coast Florida honor his colleague Jennifer Rominiecki.</p>

<p>The event began with a lively cocktail hour in the atrium before guests adjourned to the green and pink-lit ballroom, where they were met by a sea of orchid centerpieces and vibrant floral tablescapes.</p>

<p>AJC Regional Director Brian Lipton introduced Rominiecki, the president and CEO of Selby Gardens, before board member Marilyn Shuman said the motzi blessing.</p>

<p>Between courses, AJC Regional President Anne Virag give a speech titled &ldquo;The Power to Act,&rdquo; and past Civic Achievement Award Winner Veronica Brady led a tribute to Rominiecki and her many accomplishments as not only the leader of Selby but an accomplished leader for the Sarasota community as a whole since moving here in February 2015.</p>

<p>Since beginning her career at Selby, Rominiecki has helped the gardens experience a 36% increase in visitors, 29% increase in membership households and a 26% increase in overall annual revenue over two years.</p>


            </div>
            <script src="/cdn-cgi/scripts/0e574bed/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
              try { _402_Show(); } catch(e) {}
            </script>
          </div>
        </div>

        
        

      </article>

              <div class="pagination-wrapper">

                      <a href="/photo-gallery/childrens-guardian-fund-lifts-up-guests-at-annual-luncheon" class="col-1-2 bg--lightest-grey pagination-item prev">
              <div class="label left-icon">
                <span class="icon line-arrow-left-long-icon"></span>
                <span class="text">Prev Article</span>
              </div>
              <h6 class="title">Children’s Guardian Fund lifts up guests at annual luncheon</h6>
            </a>
          
          
        </div>
      
    </div> <!-- col-2-3 -->

    <div class="col-1-3 sidebar">

              <div id="ad_wrapper_t" class="advert-sidebar bg--mild-grey" data-margin="80" data-position="absolute" data-append="">
          <div id="ad_wrapper_top">
            <div id="dfp-ad-stacked_top-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-stacked_top" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-stacked_top");
      });
  </script>
</div>
</div>          </div>
        </div>
        <div class="section pad">
            <ul id="most_popular" data-margin="80" data-position="absolute" data-append=""></ul>
        </div>
      
      <div class="section pad sticky-container">
        <div id="ad_wrapper_b" class="advert-sidebar bg--mild-grey sticky" data-margin="80" data-position="absolute" data-append="">
          <div id="ad_wrapper_bottom">
            <div id="dfp-ad-stacked_bottom-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-stacked_bottom" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-stacked_bottom");
      });
  </script>
</div>
</div>          </div>
        </div>
      </div>

    </div>

  </div><!-- container -->

  

      <section class="section pad bg--lighter-grey">
      <div class="container">

        <header class="section-title">
          <h2 class="title delta bg--red">Related Stories</h2>
        </header>

        <div class="col-2-3">
          <div id="related_stories" class="section teasers"></div>
        </div>

        <div class="col-2-3 disqus--wrapper" data-scroll-anchor="disqus">
          <div id="disqus_thread"><noscript><p><a href="http://yourobserver.disqus.com/?url=https%3A%2F%2Fwww.yourobserver.com%2Fphoto-gallery%2Fajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki">View the discussion thread.</a></p></noscript></div>        </div>

      </div>
    </section>
  
  <div id="mobile_ad_container_top" class="ad-hide">
    <div id="mobile_ad_placement_top" class="advert-sidebar bg--mild-grey ad-hide" data-margin="80" data-position="absolute" data-append="">

    </div>
  </div>

  <div id="mobile_ad_container_bottom" class="ad-hide">
    <div id="mobile_ad_placement_bottom" class="advert-sidebar bg--mild-grey ad-hide" data-margin="80" data-position="absolute" data-append="">

    </div>
  </div>

</main>

      

      
    
  
</div><!-- /page-->

<div id="sticky-footer">
  <div id="dfp-ad-sticky_footer-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-sticky_footer" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-sticky_footer");
      });
  </script>
</div>
</div></div>

  

<footer class="site--footer">

      <div id="footer_ad" class="advert-bar advert-bar--footer bg--mild-grey">
      <div class="advert-wrapper">
        <div id="dfp-ad-footer-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-footer" class="dfp-tag-wrapper">
    <script async type="text/javascript">
      googletag.cmd.push(function() {
        googletag.display("dfp-ad-footer");
      });
  </script>
</div>
</div>      </div>
    </div>
  
  <div class="footer-nav">
    <div class="section bg--lightest-grey">
      <ul class="links"><li class="first leaf item-wrapper-level-1 item-1202-wrap"><a href="/about-us" class="item-1202 item-level-1">About</a></li>
<li class="leaf item-wrapper-level-1 item-1204-wrap"><a href="/contact-us" class="item-1204 item-level-1">Contact Us</a></li>
<li class="leaf item-wrapper-level-1 item-1205-wrap"><a href="http://classifieds.yourobserver.com/" class="item-1205 item-level-1">Classifieds</a></li>
<li class="leaf item-wrapper-level-1 item-1314-wrap"><a href="/advertise" title="Advertise" class="item-1314 item-level-1">Advertise</a></li>
<li class="leaf item-wrapper-level-1 item-1207-wrap"><a href="/rack-locations" class="item-1207 item-level-1">Rack Locations</a></li>
<li class="leaf item-wrapper-level-1 item-1208-wrap"><a href="/subscribe" class="item-1208 item-level-1">Subscribe</a></li>
<li class="leaf item-wrapper-level-1 item-1210-wrap"><a href="/jobs" class="item-1210 item-level-1">Jobs</a></li>
<li class="leaf item-wrapper-level-1 item-1319-wrap"><a href="/sponsorships" class="item-1319 item-level-1">Sponsorships</a></li>
<li class="last leaf item-wrapper-level-1 item-1242-wrap"><a href="/privacy-policy" class="item-1242 item-level-1">Privacy Policy</a></li>
</ul>    </div>
  </div>

  <div class="section contact-social-signup bg--lighter-grey">
    <div class="col-2-3 module">

      <div class="col-1-2 module contact">
        <h4 class="section-title text--red">Contact Us</h4>
        <img class="logo" src="/sites/all/themes/yourobserver/images/logos/logo-gray.svg" alt="Your Observer Logo" />
        <div class="grid">
          <div class="col-1-2">
            1970 Main Street <br>
                          Third Floor<br>
                        Sarasota, FL&nbsp;34236          </div>
          <div class="col-1-2">
            <b>Phone:</b> <a href="tel:941-366-3468">941-366-3468</a><br>
            <b>Fax:</b>   <a href="tel:941-362-4808">941-362-4808</a><br>
            <b>Email:</b> <a href="/cdn-cgi/l/email-protection#325b5c545d724b5d47405d504157404457401c515d5f"><span class="__cf_email__" data-cfemail="bad3d4dcd5fac3d5cfc8d5d8c9dfc8ccdfc894d9d5d7">[email&#160;protected]</span></a>
          </div>
        </div>
      </div>

      <div class="col-1-2 module socialize">
        <h4 class="section-title text--red">Socialize With Us</h4>
        <div class="grid">

        	          	<a href="https://www.facebook.com/ObserverGroup" class="icon facebook-icon col-1-6" target="_blank"></a>
          
                    	<a href="https://twitter.com/ObserverGroup" class="icon twitter-icon col-1-6" target="_blank"></a>
          
                      <a href="https://www.instagram.com/observergroup/" class="icon instagram-icon col-1-6" target="_blank"></a>
          
                    	<a href="https://plus.google.com/u/0/+Yourobserver/posts" class="icon google-plus-icon col-1-6" target="_blank"></a>
          
                    	<a href="https://www.youtube.com/user/YourObserverVideo" class="icon youtube-icon col-1-6" target="_blank"></a>
          
                    	<a href="https://www.linkedin.com/company/the-observer-group?trk=company_logo" class="icon linkedin-icon col-1-6" target="_blank"></a>
          
          
        </div>
      </div>
    </div>

    <div class="col-1-3 module signup">
      <h4 class="section-title text--red">sign up to receive our news in your inbox!</h4>
              <form class="mailchimp-signup-subscribe-form" action="//cdn.digitalobservermedia.com/yourobserver.com/email-subscribe/" method="get" target="_blank">
      <div class="form-required">
        <label class="required" for="edit-mergevars-email">Email Address</label>
        <input type="text" id="edit-mergevars-email" name="email" value="" size="30" maxlength="128" required="">
      </div>
      <input type="submit" id="edit-submit--2" value="Submit">
    </form>                </div>
  </div>

  <div class="section bg--dark-grey">
    <div class="col-4-7 module sister-sites">
      <h4 class="section-title">Our Sister Sites</h4>
      	      	      	<div class="grid"><a href="http://www.businessobserverfl.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/business.png?itok=ulxToCJ3" alt="" /></a>	      	      	      	      	<a href="http://www.palmcoastobserver.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/palmcoast.png?itok=9DShShL7" alt="" /></a></div>
                	      	      	<div class="grid"><a href="http://www.plantcityobserver.com/" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/plantcity.png?itok=sWaDULNP" alt="" /></a>	      	      	      	      	<a href="http://www.ormondbeachobserver.com" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/ormond.png?itok=d1OhVE0m" alt="" /></a></div>
                	      	      	<div class="grid"><a href="http://www.orangeobserver.com" target="_blank" class="col-1-2"><img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/sister_sites_560x48/public/media/orange.png?itok=ky46z5ix" alt="" /></a>	      	      	                  </div>
	                </div>

    <div class="col-3-7 right module other-pubs">
      <h4 class="section-title">Other Publications</h4>
      <div class="inner">
                	<img typeof="foaf:Image" src="https://www.yourobserver.com/sites/default/files/styles/other_publications_200x140/public/media/other-pubs_0_0.png?itok=7SbC7L-C" alt="" />                <p>
        	        		Browse a digital collection of our other publications, magazines and special sections such as Season Magazine, Health Matters, Holiday Gift Guide and more .        	        </p>
        <a href="/e-editions" class="button">VIEW ALL<span class="cta-right"></span></a>      </div>
    </div>
  </div>

  <div class="copy-bar">
    <span class="text">Copyright &copy;&nbsp;2017&nbsp;Observer Media Group, Inc., All Rights Reserved</span>
    <a class="right" href="http://www.atlargeinc.com" target="_blank"><img src="/sites/all/modules/features/tog_site_wide/theme/atlarge-logo.svg" alt="Site created by atLarge inc."></a>
  </div>

</footer>

  
  <script src="/cdn-cgi/scripts/0e574bed/cloudflare-static/email-decode.min.js"></script><script src="/sites/all/modules/custom/tog_most_popular/js/tog_most_popular_track.js?ozlc82"></script>
<script src="https://www.yourobserver.com/sites/default/files/js/js_nwQXP3ADebEgUZygxA88EYpJ5m8A9uFy-JruZMnUNyM.js"></script>
<script src="/sites/all/modules/custom/tog_most_popular/js/tog_most_popular.js?ozlc82"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_share.js?ozlc82"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_related.js?ozlc82"></script>
<script src="/sites/all/modules/features/tog_people/js/tog_people_stories.js?ozlc82"></script>
<script src="/sites/all/modules/features/tog_planned_story/js/tog_planned_story_disqus.js?ozlc82"></script>
      <script type="application/ld+json">
      {"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.yourobserver.com\/photo-gallery\/ajcs-2017-civic-achievement-award-dinner-honors-jennifer-rominiecki"},"headline":"AJC\u2019s 2017 Civic Achievement Award Dinner honors Jennifer Rominiecki","image":{"@type":"ImageObject","url":"https:\/\/www.yourobserver.com\/sites\/default\/files\/styles\/sliders_and_planned_story_image_870x580\/public\/143035_standard.jpeg?itok=Y62OqSFp","height":580,"width":870},"datePublished":"2017-11-17T17:25:00-05:00","dateModified":"2017-11-17T21:30:01-05:00","author":{"@type":"Person","name":"Niki Kottmann"},"publisher":{"@type":"Organization","name":"Your Observer","logo":{"@type":"ImageObject","url":"https:\/\/www.yourobserver.com\/sites\/all\/themes\/yourobserver\/images\/logos\/logo-bright.png","width":323,"height":33}},"description":"The annual award dinner recognized the president and CEO of Marie Selby Botanical Gardens on Nov. 16 at Michael\u2019s On East."}    </script>
    </body>
</html>
